LINUX.ORG.RU

Calculate Linux 17

 ,


0

1

Доступны для загрузки следующие редакции дистрибутива: Calculate Linux Desktop с рабочим столом KDE (CLD), Mate (CLDM) и Xfce (CLDX), Calculate Linux Scratch (CLS), Calculate Directory Server (CDS), Calculate Scratch Server (CSS) и Timeless.

Основные изменения

  • Новый серверный дистрибутив Timeless
    • Переписана часть функционала утилит настройки сервера. Для тестирования новых утилит подготовлен дистрибутив Timeless, который по завершению работы будет объединён с Calculate Directory Server. Доступны следующие модули:
      • Настройка LDAP-сервера
      • Работа с учётными записями в LDAP
      • Создание резервной копии
    • Среди особенностей новых утилит можно отметить:
      • Поддержка работы как в консоли, так и в графическом интерфейсе
      • Клиент-сервеная архитектура
      • Интеграция с пакетным менеджером
      • Единое хранение шаблонов настроек
  • Графический менеджер
    • Изменено оформление, добавлены собственные иконки
    • Изменён запуск через иконку обновлений в системном трее.
    • Улучшена поддержка системной цветовой схемы.
  • Консольный менеджер
    • Единая сессия для cl-console и cl-console-gui. К задаче, запущенной в графическом менеджере, теперь можно подключиться из консоли и наоборот.
    • Консольные утилиты стали доступны для запуска пользователю, работает через вызов cl-console.
  • Live USB
    • Добавлена поддержка выбора загрузки системы без использования PulseAudio.
    • Исправлена загрузка с жесткого диска при выборе русского языка.
  • Утилиты Calculate
    • Множественные улучшения в шаблонах: новые функции, поддержка условий «или», поддержка указания интервала в условных выражениях, поддержка запуска служб, связывания файлов с установленными пакетами, понижения версии установленного пакета, поддержка формата ldif и т.д.
  • Прочее
    • В ночных сборках можно скачать бета-версии двух новых дистрибутивов Calculate Linux Desktop Cinnamon и Calculate Linux Desktop LXQt.
    • Количество бинарных пакетов в репозитории увеличено до 5 тыс.
    • В десктопах сменён браузер на Firefox, получивший более 100 улучшающих производительность и анонимность работы настроек.
    • MATE обновлён до версии 1.16 и переведён на использование библиотеки GTK+ 3.
    • В репозитории бинарных пакетов всегда доступно самое свежее ядро.
    • Добавлена поддержка клавиши Compose (правый Alt) для ввода спецсимволов, в т. ч. знаков валют рубль и гривна (₽, ₴).
    • Множественная обработка ini.env по разным путям с переносом части настроек профиля пользователя.
    • Прекращена поддержка проприетарного видеодрайвера ati-drivers.
    • Добавлена поддержка установки дистрибутива на NVMe устройства.
    • Добавлена поддержка централизованной настройки доступа к su для доменных пользователей.
    • Исправлено шифрование пользовательского профиля.

Состав пакетов

  • CLD (KDE desktop):
    KDE Frameworks 5.29, KDE Plasma 16.12, KDE Applications 16.12, LibreOffice 5.2.3.3, Firefox 50.1.0, Gimp 2.8.16, Clementine 1.3.1
    i686 - 1.92 G, x86_64 - 2.08 G
  • CLDM (MATE desktop):
    MATE 1.16, LibreOffice 5.2.3.3, Firefox 50.1.0, Claws Mail 3.14.1, Gimp 2.8.16, Clementine 1.3.1
    i686 - 1.53 G, x86_64 - 1.69 G
  • CLDX (Xfce desktop):
    Xfce 4.12, LibreOffice 5.2.3.3, Firefox 50.1.0, Claws Mail 3.14.1, Gimp 2.8.16, Clementine 1.3.1
    i686 - 1.44 G, x86_64 - 1.61 G
  • CDS (Directory Server):
    OpenLDAP 2.4.43, Samba 4.2.14, Postfix 3.1.2, ProFTPD 1.3.5b, Bind 9.10.3
    i686 - 644 M, x86_64 - 669 M
  • CLS (Linux Scratch):
    Xorg-server 1.17.4, Kernel 4.4.9
    i686 - 724 M, x86_64 - 823 M
  • CSS (Scratch Server):
    Kernel 4.4.39, Calculate Utilities 3.5.0.10
    i686 - 445 M, x86_64 - 471 M
  • Timeless (New server):
    OpenLDAP 2.4.43, Calculate Utilities 3.5.0.10
    i686 - 467 M, x86_64 - 493 M

Ссылки

>>> Анонс

★★★★

Проверено: JB ()
Ответ на: комментарий от anonymous

так хочется иметь иллюзию gentoo и, при этом, не напрягать мозг - калька для тебя. калька - иллюзия gentoo.

anonymous ()
Ответ на: комментарий от anonymous

Мне не нужно, чтобы за меня решал неизвестный эксперт, меня мнения интересуют. В документации рекомендуют

/dev/sda1 swap

/dev/sda2 10-20Gb Linux (/)

/dev/sda3 10-20Gb Linux (/)

/dev/sda4 Extended

/dev/sda5 Linux (/home)

но оправданно ли держать для переустановки дополнительный раздел 10-20Gb на 120Gb?

Может лучше как-то так

/dev/sda1 4Gb swap

/dev/sda2 20Gb (/) ext2

/dev/sda3 всё остальное (/home) ext4

Или вообще

/dev/sda1 4Gb swap

/dev/sda2 всё остальное (/) ext2

sulevaz ()
Ответ на: комментарий от anonymous

поставь десяточку.

Это намёк на стабильность системы? На десяточке я не держу образ восстановления системы и ни разу не понадобился. Если у калькулейт со стабильностью работы не хуже, то и здесь не должен понадобиться дополнительный раздел.

sulevaz ()
Ответ на: комментарий от NextGenenration

и в федоре он работает без наличия одновременно нескольких версий.

Ты хотел сказать не «без наличия», а «благодаря наличию».

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Ты хотел сказать не «без наличия», а «благодаря наличию».

Я сказал то что хотел сказать

NextGenenration ()
Ответ на: комментарий от dexpl

Тогда это 4.2.

Пруф в студию. Только не приводи gtk2 и gtk3 - они являются разными пакетам.

NextGenenration ()
Ответ на: комментарий от NextGenenration

Пруф в студию.

Пруф чего? Нет, я правда не понимаю, откуда ты взял возможность выбрать версию того или иного пакета, если в репозитории данный пакет — только одной версии, и как ты себе представляешь такое технически. А в "родных" репозиториях федоры в каждый момент времени каждый пакет, кроме ядра, присутствует в единственной версии (если *testing не включать).

dexpl ★★★★★ ()
Ответ на: комментарий от sulevaz

Мне не нужно, чтобы за меня решал неизвестный эксперт, меня мнения интересуют

какие мнения? кто, кроме тебя, знает, что ты хочешь получить? надежность, скорость, гибкость или еще что-то?

genoo выбирают тогда, когда понимают, что хотят получить. ставить calculate чтобы не «заморачиваться» с gentoo - нонсенс, абсурд! если ты не знаешь, чего хочешь, зачем тебе gentoo? если знаешь, зачем тебе calculate???

anonymous ()
Ответ на: комментарий от dexpl

Нет, я правда не понимаю, откуда ты взял возможность выбрать версию того или иного пакета, если в репозитории данный пакет — только одной версии, и как ты себе представляешь такое технически

Далеко не каждый пакет можно даунгрейдить. Я почему спросил: все пакеты которые я просматривал в репах генты имели как минимум две версии

NextGenenration ()
Ответ на: комментарий от NextGenenration

Далеко не каждый пакет можно даунгрейдить.

Вот и я об этом: если данный пакет в репе — в единственной версии, то хрен его даунгрейднешь.

Я почему спросил: все пакеты которые я просматривал в репах генты имели как минимум две версии

Видимо, гентушники (или у кого там так) любят даунгрейдить :)

dexpl ★★★★★ ()
Ответ на: комментарий от RedEyedMan4

Год не год, а три месяца не обновляю уже. Ошибку уже нашел, но один хрен - лень обновлять.

newprikolist ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.