LINUX.ORG.RU

Релиз AOSP 4.2

 , ,


0

1

13 ноября 2012 года, совместно с началом продаж новых устройств Google Nexus 4 (ODM — LG) и Google Nexus 10 (ODM — Samsung), состоялся релиз AOSP (Android Open Source Project) версии 4.2. На текущий момент доступны как исходный код, так и образы прошивок.

Кратко о поддерживаемых устройствах:

  • Google Nexus 10 наиболее поддерживаемое устройство со стороны AOSP — закрытая только прошивка (firmware) для GPU.
  • Google Nexus 4 на текущий момент не поддерживается AOSP.
  • Google Nexus S и Motorola Xoom не будут поддерживаться в 4.2 и должны использовать версию 4.1.2.

Информацию об изменениях пользовательского интерфейса можно почитать здесь.

>>> Подробности

★★★

Проверено: maxcom ()

Google Nexus S

длительная поддержка Nexus'ов не такая длительная, по факту, так? И ведь в этом релизе даже никаких особых улучшений нет, то есть это у гугла политика такая. Ну отлично, только яббл, значит, действительно заботится о пользователях. Следующий релиз андроида не выйдет уже для Galaxy nexus, получается?

RedPossum ★★★★★ ()

сильно хотелось съязвить, но решил этого не делать

xtraeft ★★☆☆ ()
Ответ на: комментарий от RedPossum

Ну отлично, только яббл, значит, действительно заботится о пользователях.

Пусть сначала исходники откроет.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от Black_Shadow

Пусть сначала исходники откроет.

и сразу легче станет? Ось то у них не очень какая-то. Страшненькая и неюзабельная. Но зато всегда свежая.

RedPossum ★★★★★ ()
Ответ на: комментарий от Black_Shadow

CyanogenMod всё равно будет для Nexus S.

ммм, ну отлично, телефону то чуть меньше двух лет,а поддержки уже нет, зато есть цианоген. Глобально и надежно.

RedPossum ★★★★★ ()
Ответ на: комментарий от xtraeft

Да. Есть исходники - есть сторонние прошивки. Типа Cyanogenmod, который по качеству лучше многих родных прошивок.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от Black_Shadow

кстати о cm, для некоторых устройств вышел cm10 stable, вчера свой sgnex обновил

etwrq ★★★ ()
Ответ на: комментарий от RedPossum

Яббл тоже со временем бросает старые устройства. Тот же 3g уже не поддерживается.

vurdalak ★★★★★ ()
Ответ на: комментарий от vurdalak

Тот же 3g уже не поддерживается.

3г 2008г
Google Nexus S 2010г
Motorola Xoom 2011г

ощути, что называется разницу...

F457 ★★★ ()
Ответ на: комментарий от F457

Посчитай количество вышедших за это время моделей айфона и нексусов.

vurdalak ★★★★★ ()
Ответ на: комментарий от F457

ощути, что называется разницу...

Фигня это, а не разница.
Nokia Lumia 900 - июнь 2012, но wp8 ей не светит. Вот это я понимаю забота о пользователях.

Tigger ★★★★ ()
Ответ на: комментарий от vurdalak

Посчитай количество вышедших за это время моделей айфона и нексусов.

Эм, их больше вышло или меньше? Только конечному пользователю смарта от этого не холодно и не жарко. А вот то, что его телефон больше не получит обновлений...

F457 ★★★ ()
Ответ на: комментарий от Tigger

Замечательная логика: у андроида маленький срок подержки смартов, но это не беда, ибо никому не нужный телефон остался вообще без обновлений...

F457 ★★★ ()
Ответ на: комментарий от vurdalak

Тот же 3g уже не поддерживается.

3 года поддерживали, да и там отказ от поддержки, ЕМНИП, обуславливался отсутствием технических возможностей устаревшего устройства. А здесь ничего же не поменялось, та же желейная конфета

RedPossum ★★★★★ ()
Ответ на: комментарий от F457

Так не покупай ведроид, а купи огрызок, делов-то.

Tigger ★★★★ ()
Ответ на: комментарий от F457

Нексусов, ЕМНИП, больше. Андроид развивается быстрее, поэтому и поддержка старых устройств бросается быстрее. Плюс количество устройств: одно дело запилить новую версию на 3,5 айфона, и другое дело — на десяток нексусов. У гугла ресурсов на все это не хватает, вот он старые и выбрасывает.

vurdalak ★★★★★ ()

Почему в sdk образе ядро 2.6.29?, на nexus'ах тоже такое ядро

GanGSISoft ★★ ()
Ответ на: комментарий от RedPossum

Два года вполне нормальный срок для поддержки телефона. Многие и полгода не поддерживают.

mono ★★★★★ ()
Ответ на: комментарий от vurdalak

Нексусов, ЕМНИП, больше.

Nexus One, Nexus S, Galaxy Nexus, Nexus 4 - телефоны. Nexus 7, Nexus 10 - планшеты.

тем временем у умирающего яблока: iPhone, iPhone 3G, iPhone 3gs, iPhone 4, iPhone 4s, iPhone 5 + iPad, iPad2, the new iPad, iPad with Retina Display, iPad mini. И это не считая уймы iPod'ов.

Итого: google - 6. Apple - 11.

Если считать что еще поддерживается гугл тоже проигрывает.

RedPossum ★★★★★ ()
Ответ на: комментарий от mono

Два года вполне нормальный срок для поддержки телефона.

ну кто же спорит, у меня лично телефоны живут не больше года, но осадочек неприятный

RedPossum ★★★★★ ()
Ответ на: комментарий от RedPossum

Ты пропустил один самсунговский нексус с 4 андроидом и xoom. Это как минимум, то, что я помню. А а ионы с буквой s отдельными можно не считать, там поддержка не нужна, ибо железо кроме мощности ничем не отличается.

vurdalak ★★★★★ ()
Ответ на: комментарий от vurdalak

моторола xoom тоже нексус? С чего бы это? Только то что это был первый планшет с Honeycomb еще ни о чем не говорит.

самсунговский нексус с 4 андроидом

нексусы S все с 4м андроидом и от самсунга.

железо кроме мощности ничем не отличается.

Это ты так решил только потому что они выглядят одинаково?

И вообще, какие отличия между 4.1 и 4.2? Да никаких, какие-то все невнятные и мелкие. И ты думаешь гугл не справился с 4.2 для Nexus S?

RedPossum ★★★★★ ()
Ответ на: комментарий от RedPossum

нексусы S все с 4м андроидом и от самсунга.

С обновлениями. А еще есть один, где 4-ка была изначально.

И вообще, какие отличия между 4.1 и 4.2? Да никаких, какие-то все невнятные и мелкие. И ты думаешь гугл не справился с 4.2 для Nexus S?

Справился бы. Но у него нет лишних рабочих, которые напишут 4.2 для этой модели.

vurdalak ★★★★★ ()
Ответ на: комментарий от RedPossum

Ну отлично, только яббл, значит, действительно заботится о пользователях.

Ага, то-то повсюду вопли яблочников, у которых все глючит и тормозит после обновлений, и которые не могут нормальным образом откатиться.

trycatch ★★★ ()
Ответ на: комментарий от RedPossum

Моторола xoom не нексус, но попал под аналогичную программу обновлений.

mono ★★★★★ ()

Google Nexus 4 на текущий момент не поддерживается AOSP.

Вот этого совсем не понимаю.

Jaga ★★ ()

P.S. Для Google Galaxy Nexus (ODM — Samsung) уже доступны OTA и Factory Images.

только для модели с поддержкой Google Wallet. Говорят можно и на обычную поставить, но я бы не рисковал

JB ★★★★★ ()
Ответ на: комментарий от Jaga

Вот этого совсем не понимаю.

AFAIK, там с драйверами затык

JB ★★★★★ ()
Ответ на: комментарий от Black_Shadow

Ну отлично, только яббл, значит, действительно заботится о пользователях.

Пусть сначала исходники откроет.

можешь помедитировать на исходники, только поддержка твоего устройства производителем от этого не появится. Вот и начал гугл давить старые устройства - что бы новые покупали...

anonymous ()
Ответ на: комментарий от vurdalak

И вообще, какие отличия между 4.1 и 4.2? Да никаких, какие-то все невнятные и мелкие. И ты думаешь гугл не справился с 4.2 для Nexus S?

Справился бы. Но у него нет лишних рабочих, которые напишут 4.2 для этой модели.

Так он же производитель ? почему у apple есть лишние руки писать обновления на кучу девайсов - а у Google нету. Может по тому что Google хочет вас стимулировать покупать новые телефоны и увеличивать себе прибыль?

anonymous ()
Ответ на: комментарий от anonymous

почему у apple есть лишние руки писать обновления на кучу девайсов - а у Google нету

Потому что гугл занимается не только телефонами. И потому что он, в отличие от яббла, прибыли с нексусов не имеет (не он их производит, он только дает им право использовать бренд nexus).

vurdalak ★★★★★ ()
Ответ на: комментарий от anonymous

можешь помедитировать на исходники, только поддержка твоего устройства производителем от этого не появится.

Появится. Есть неродные прошивки, которые лучше и стабильнее родных.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от RedPossum

Пусть сначала исходники откроет.

и сразу легче станет?

легче станет, если можно будет ставить андроид на айфончики

autonomous ★★★★ ()
Ответ на: комментарий от Black_Shadow

Появится. Есть неродные прошивки, которые лучше и стабильнее родных.

не появится, если не будет нужных драйверов

autonomous ★★★★ ()
Ответ на: комментарий от Black_Shadow

Есть исходники - есть сторонние прошивки.

Скажи это пользователям Motorola, например.

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

На мотороллерах рулит и педалит 2ndboot, хотя тивоизация - зло и те манагеры, которые решили блочить бутладер должны гореть в аду, я считаю.

anonymous ()

Вышел AOSP версии 4.2

Разработчики CyanogenMod: Черт, а мы толь 4.1 собрали.

Freiheits-Sender ★★ ()
Ответ на: комментарий от RedPossum

ммм, ну отлично, телефону то чуть меньше двух лет,а поддержки уже нет, зато есть цианоген. Глобально и надежно.

Как будто когда-то было по другому.

m0rph ★★★★★ ()
Ответ на: комментарий от JB

только для модели с поддержкой Google Wallet. Говорят можно и на обычную поставить, но я бы не рисковал

Я прошил оттуда только system.img на свой toro, boot.img собрал сам из AOSP. Полёт нормальный.

Dendy ★★★★★ ()
Ответ на: комментарий от autonomous

если можно будет ставить андроид на айфончики

извращение какое. тормозить же будет

RedPossum ★★★★★ ()

Что значит - не поддерживается?
Они просто не переносят драйвера устройств из более ранних версий?
Вроде там больше нечему «неподдерживаться».

d9d9 ★★★ ()
Ответ на: комментарий от vurdalak

А а ионы с буквой s отдельными можно не считать, там поддержка не нужна, ибо железо кроме мощности ничем не отличается.

ios6 не поддерживает 3g, но поддерживает 3gs

xtraeft ★★☆☆ ()
Ответ на: комментарий от xtraeft

Тот же вопрос, что и с андроидом: почему, если 3g и 3gs мало чем отличаются?

vurdalak ★★★★★ ()
Ответ на: комментарий от vurdalak

почему, если 3g и 3gs мало чем отличаются?

это утверждение ты видимо сам придумал, сходи что ли в википедию хотя бы для начала.

xtraeft ★★☆☆ ()
Ответ на: комментарий от vurdalak

встречный вопрос - почему андроид 4.x неофициально заводится на старых девайсах, а официально - «увы, это древнее барахло физически не может запускать новые версии android, предлагаем вам купить новый»?

xtraeft ★★☆☆ ()
Ответ на: комментарий от xtraeft

«увы, это древнее барахло физически не может запускать новые версии android, предлагаем вам купить новый»

Никто так не говорит. Просто им честно лень тратить ресурсы и адаптировать новую версию, и это приходится делать сообществу.

vurdalak ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.