LINUX.ORG.RU

Не регулируется яркость экрана ноутбука asus zenbook ux302lg на Debian

 , , , ,


1

1

Ноутбук Asus Zenbook UX302LG
Системы Debian jessie/sid
Пробовал ядра 3.13, 3.14

При загрузке появлялся черный экран. Нагуглил, что это проблемы с KMS. Как решать не написано, кроме как выключить KMS i915.modeset=0.

С modeset=0 загрузка проходит нормально, но не работает драйвер видеокарточки intel при запуске X. Пишет No such device

Но X нормально запускается с драйвером fbdev или vesa. При этом если в BIOS стоит Enabled CMS то максимальное разрешение 1024х768, если Disabled CMS то с начала загрузки разрешение 1920x1080.

Казалось бы можно поставить Disabled CMS и modeset=0 и жить хорошо, но не работает изменения яркости экрана, всегда 100%. При этом если поставить acpi_osi= или acpi_backlight=vendor или и то и другое, то начинают работать большинство Fn клавиш (включая подсветку клавиатуры), но подсветка экрана не работает.

При регулировки через настройки KDE или через запись в /sys/class/backlight/asus-nb-wmi/brightness значение записывается, на экране появляется ползунок яркости, но яркость экрана при этом не меняется.

Пробовал ставить acpi_osi="!Windows 2012", acpi_osi=Linux, acpi_backlight=legacy.

Добавлял модули i915, intel_agp в /etc/initramfs-tools/modules и делал update-initramfs -u

Ничего не помогает.

1. Как можно починить яркость куда копать?
2. Правильно я понимаю, что драйвер intel не будет работать без KMS?
3. Что можно сделать, чтобы KMS заработал?

PS
/etc/X11/xorg.conf отсутствует
lspci

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 2 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 5 (rev e4)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation Lynx Point-LP Thermal (rev 04)
02:00.0 Unassigned class [ff00]: Device 1aea:6601
03:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)
04:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev ff)

Вторая карточка это Nvidia (с поддержкой Optimus).

попробуй в конфиге grub: (/etc/default/grub)

строку

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
заменить на
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
и после
sudo update-grub

garik_keghen ★★★★★ ()
Ответ на: комментарий от garik_keghen

если поставить acpi_osi= или acpi_backlight=vendor или и то и другое, то начинают работать большинство Fn клавиш (включая подсветку клавиатуры), но подсветка экрана не работает

Towelie ()

Нагуглил эту проблему. В результате поставил последнее ядро собранное за день до этого (какими-то хорошими людьми)

Взял тут http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/2014-05-17-ut...

С этим ядром работает KMS, а следовательно подгружается драйвер intel и в итоге заработало изменение яркости чрез переменные в /sys/class...

А уж написать 4 скрипта и привязать их к Fn + клавишам это просто.

Всем спасибо.

kirimedia ()
Ответ на: комментарий от kirimedia

С этим ядром работает KMS, а следовательно подгружается драйвер intel

а типа раньше он не грузился?

false ★★★★★ ()
Ответ на: комментарий от false

Раньше не грузился без modeset=0. При загрузке появлялся черный экран и все из за того что KMS не мог правильно выставить разрешение. А с modeset=0 грузился, но драйвер Intel не работал.

kirimedia ()
Ответ на: комментарий от kirimedia

Круто у тебя libastral прокачан, конечно. У меня-то всё банальнее было - баг в подсветке.

false ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.