LINUX.ORG.RU

Копирование Slackware с одного HDD на другой.


0

2

День добрый товарищи. у меня проблема с lilo он выдает ошибки на том харде куда я скопировал систему. опишу все что я делал подробно что бы было понятно что не так делаю. Раньше я так копировал все было норм, но я забыл пару моментов, по этому в этот раз не получается(((( надеюсь сможете помочь мне. а может вообще по проще способ знаете для переноса всего этого...

slackware 13.37.0 lilo 22.8

sda - источник (80GB) sdb - чистый (160GB) adc - с него загрузился

1) разбил диск точно так же как на источнике. cfdisk /dev/sdb

2) создал разделы: mkswap /dev/sdb1 mkfs.ext4 /dev/sdb2 mkfs.ext4 /dev/sdb3

3) создаю директории mkdir /mnt/src /mnt/dst

4) монтирую источник sda2 mount /dev/sda2 /mnt/src mount /dev/sdb2 /mnt/dst

5) копирую sda2 cp -pRv /mnt/src/* /mnt/dst

6) монтирую источник sda3 mount /dev/sda3 /mnt/src/var/ mount /dev/sdb3 /mnt/dst/var/

7) копирую sda3 cp -pRv /mnt/src/var/* /mnt/dst/var

8) сменить окружение chroot /mnt/dst/

9) отредактировать лило mcedit /etc/lilo.new.conf

10) загрузчик на новый HDD lilo -C /ect/lilo.new.conf exit halt

ниже опишу те пункты которые не работают. 9) тут я забыл что надо было подправить в лило((( помоему что-то в этих строках (насколько помню sdc на sdb) disk=/dev/sdс bios=0x80 boot = /dev/sdс

10) выдает ошибку warning: LBA32 addressing assumed warning: the boot sector and map file are on different disks. added linux * 2 warnings were issued.

3) создаю директории иногда не создаются почему то((( позже напишу что за ошибку выдает.


disk=/dev/sdс bios=0x80 boot = /dev/sdс

Скорее всего тут 0x81 должно быть, так как 0x80 — первый диск, но я не уверен. И диск указать тот, с которого грузишься — /dev/sdb но это ты вроде и сам понял. В чём вопрос-то?

И да, кажется, при таком копировании не сохраняются даты изменения файлов или я что-то не так делал, но обнаружил что они сбились. Вместо cp лучше примени tar или cpio или rsync. Работать впрочем и так будет.

Xenius ★★★★★
()
Последнее исправление: Xenius (всего исправлений: 1)
Ответ на: комментарий от Xenius

После всего проделанного. с того нового диска не грузится слаквайр. после загрузки биуса. идет запуск лило. но он не запускается. там даже ошибку не выдает. просто какие то цыфры. а иногда вообще просто черный экран...

Arven
()
Ответ на: комментарий от Arven

Можешь попробовать syslinux (он же extlinux и isolinux. Конфиг называется syslinux.cfg не перепутай. В новой версии syslinux это имя для всех видов, а в extlinux расширение extlinux.conf

Xenius ★★★★★
()
Ответ на: комментарий от w1nner

думаешь я не пробовал? раз 5 делал. не получается. значит в каком то пушке не так делаю. а вот в каком?

Arven
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.