LINUX.ORG.RU

E-mu 0404 USB S/PDIF In - нет звука

 , ,


0

1

Всем привет.
Имеем на выходе - S/PDIF Out - 00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
Имеем на входе - S/PDIF In - Bus 002 Device 002: ID 041e:3f04 Creative Technology, Ltd E-Mu 0404

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: USB [E-MU 0404 | USB], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: USB [E-MU 0404 | USB], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ cat /proc/asound/devices
  0: [ 0]   : control
  1:        : sequencer
  4: [ 0- 0]: hardware dependent
 16: [ 0- 0]: digital audio playback
 17: [ 0- 1]: digital audio playback
 24: [ 0- 0]: digital audio capture
 25: [ 0- 1]: digital audio capture
 26: [ 0- 2]: digital audio capture
 32: [ 1]   : control
 33:        : timer
 40: [ 1- 0]: raw midi
 48: [ 1- 0]: digital audio playback
 49: [ 1- 1]: digital audio playback
 56: [ 1- 0]: digital audio capture
$ time aplay -D hw:0,1 test_stereo_44100Hz_16bit_PCM.wav 
Playing WAVE 'test_stereo_44100Hz_16bit_PCM.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

real    0m14.732s
user    0m0.010s
sys     0m0.000s
т.е. якобы должен быть звук, а звука нет.
qmmp & deadbeef файл проигрывают, а звука нет.
делал как тут - http://alsa.opensrc.org/DigitalOut, и тут -http://ubuntuforums.org/showthread.php?t=1340538, - написано, не помогло.
есть методы решения этой проблемы?
Ещё при прогоне тестов на E-mu в Sync Status горит индикатор Int, а Ext моргает
Система Arch x86_64


Ответ на: комментарий от anonymous

aka PG007. галочки все выставлял, всё подряд включал, разные Sync Clock'и пробовал; сделал по мануалу, чтоб Sync Clock был External, звука не было, пока не включил Direct Monitoring->Main. На ixbt'e тоже про Direct Monitoring пишут, только вот я не догоняю, причём тут Direct Monitoring.

anonymous ()

Покажи aplay -L. Есть ли .asoundrc или asound.conf? Есть подозрение, что 0404 не стоит по умолчанию на вывод звука. Попробуй еще явно в настройках deadbeef сделать вывод на 0404.

Dzusan ()
Ответ на: комментарий от Dzusan

да, звук есть, надо часто лазить в алсамиксер для переключения синхронизации. короче, геморно это. оставил как есть чрез УСБ; это проще. кста, выявил, что для регуляровки звука чрез kMix надо ставить пульсу; с X-Fi Music такого не было.

PG_007 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.