LINUX.ORG.RU

[arch] [ati] [driver] [слёзы]


0

0

Добрый вечер ЛОР. Случилась у меня одна беда - не могу поставить нужное разрешение экрана для своего TFT монитора(Dell E177FPf), на видеокарте ATI Radeon 9550. Точнее могу, но изображение выводит не правильно. На экране оно получается вытянутое по вертикали с чёрными полосами по горизонтали(1-2см) сверху и снизу. А когда делаю скриншот, то на нем изображение просто растянуто во вертикали без полос. Устанавливал я свободные драйвера, делал по арчеровской ВиКи, но автоматом нужное разрешение он не подхватил, только 1024х768, а мне надо 1280х1024. Я выполнил X -configure, тем самым что бы внести туда:

# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync
HorizSync      31-81
VertRefresh   56-75
и
Modes 1280х1024

Все это записывалось в соответствующие секции. Вводил следующие команды:

xrandr --newmode "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync
xrandr --addmode VGA-0 1280x1024_60.00
xrandr --output VGA-0 --mode 1280x1024_60.00
и на экране получилось то, о чём я написал в самом начале. Но почему то когда в xorg.conf пишу вместо radeon -> vesa, видюшка сразу подхватывает нужное разрешение, т.е получается дело в драйвере? Смотрел я в /var/log/Xorg.0.log, там только одна ошибка и то ругается на китайскую мышку(что то вроде - Relative Axis). Да еще в консольке писал:
glxinfo | grep direct  --> Direct rendering : Yes
fglxgears --> 59.789 попугаев(меняется)
Подскажите что я делаю не так? Или как мне поставить нужное разрешение? P.S. Просьба сильно не пинать, гугл не помог(. Чёрт ну и каша получилась лор код(. Upd: поправил.


Есть какие нибудь идеи? Неужели придется ставить XPюшку? На ней я проверял все работает, т.е. железки не виноваты.

Xe0N ()
Ответ на: комментарий от RussianNeuroMancer

Сейчас спрошу на русском форуме Archlinux, посмотрим что там скажут, если что придется писать. Примечательно то что эта проблема повторялась на Debian Stable и Ubuntu 11.10.

Xe0N ()
Ответ на: комментарий от RussianNeuroMancer

Скорее всего в драйвере т.к. vesa хавает то). Только что попробывал xorg не реагирует на HorizSync вообще(.

Xe0N ()
Ответ на: комментарий от Xe0N

Проблема решена установкой из AURa драйвера xf86-video-ati-git 20110813-1.

Xe0N ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.