LINUX.ORG.RU

gentoo + emerge


0

0

чего то как не пойму:
вот например мне нужно сделать след вещь:( для примера )
ставить последние нестабильные пакеты в системе
если я указываю
ACCEPT_KEYWORDS="~x86" - то ставяться непоследние нестабильные пакеты ....
еще один вопрос:
предположим я указал в package.keywords
<=xfce-base/xfce4-panel-4.2.1 и тут появилась версия xfce-base/xfce4-panel-4.2.1.1 для того чтобы мне ее поставить нужно зайти в портежи посмотреть что она появилась и соотв поправить этот файл
а можно сделать так что например в стабильной системе с ACCEPT_KEYWORDS="x86" можно было ставить последний нестабильный пакет не заботясь о его версии ? ....

anonymous

Re: gentoo + emerge

$ cat /etc/portage/package.keywords
app-shells/bash ~x86
#mail-mta/nbsmtp ~x86
#net-misc/proxychains ~x86
#app-portage/deltup ~x86
#app-dicts/stardict ~x86
#app-dicts/stardict-jmdict-en-ja ~x86
x11-wm/icewm ~x86
dev-libs/glib ~x86
#net-www/opera ~x86
sys-apps/util-linux ~x86
#app-editors/kvim ~x86
app-arch/p7zip ~x86
#sys-devel/gcc ~x86
#sys-libs/libstdc++-v3 ~x86
sys-fs/e2fsprogs ~x86
sys-apps/baselayout ~x86
sys-libs/readline ~x86
sys-apps/sysvinit ~x86
media-video/nvidia-kernel ~x86
media-video/nvidia-glx ~x86

man portage

anonymous ()
Ответ на: Re: gentoo + emerge от anonymous

Re: gentoo + emerge

ну вот смотри поставил в package.keywords
app-office/openoffice-bin ~x86


emerge --tree --deep --pretend world

app-office/openoffice-bin-1.1.4-r1 [1.9.91-r2]

т е почему предлагает ставить старый оффис ?

anonymous ()
Ответ на: Re: gentoo + emerge от anonymous

Re: gentoo + emerge

или то же самое с dev-db/pgadmin3 ~x86
предлагает ставить версию dev-db/pgadmin3-1.0.2 вместо dev-db/pgadmin3-1.2.0 .... т е нужно сначала указать что то в файлах package.mask и package.unmask - только потом можно это делать ...
получается неправильно определяются версии ?

anonymous ()

Re: gentoo + emerge

>ACCEPT_KEYWORDS="~x86" - то ставяться непоследние нестабильные пакеты ....

ставятся нестабильные

>предположим я указал в package.keywords <=xfce-base/xfce4-panel-4.2.1 и тут появилась версия xfce-base/xfce4-panel-4.2.1.1 для того чтобы мне ее поставить нужно зайти в портежи посмотреть что она появилась и соотв поправить этот файл

тебе уже показали, как править package.mask

>а можно сделать так что например в стабильной системе с ACCEPT_KEYWORDS="x86" можно было ставить последний нестабильный пакет не заботясь о его версии ? ....

да. /etc/portage/package.keywords

Expert ()
Ответ на: Re: gentoo + emerge от Expert

Re: gentoo + emerge

>тебе уже показали, как править package.mask

пардон, package.keywords

Expert ()
Ответ на: Re: gentoo + emerge от anonymous

Re: gentoo + emerge

>т е почему предлагает ставить старый оффис ?

какая буква стоит перед app-office/openoffice-bin-1.1.4-r1 [1.9.91-r2]

Expert ()
Ответ на: Re: gentoo + emerge от Expert

Re: gentoo + emerge

какая буква стоит перед app-office/openoffice-bin-1.1.4-r1 [1.9.91-r2]
ND вроде бы ...
а вообще я тут покумекал и понля что получается если например в world прописать например только mplayer например - то будет обновлять то что относиться к mplayerу + зависимости изредка ( если новые версии появяться ) а так остальные пакеты старые остануться ? т е получается вроде бы как парадокс если не указывать ВСЕ в world то через 2 месяца обновлений так старая система и останется ( ну кроме mplayer + зависимости ) ?
а если ВСЕ обновлять - так это наверное запаришься :) ....

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.