LINUX.ORG.RU

nvidia/nouveau и openSUSE


0

1

господа, как удалить закрытый драйвер nvidia и установить вместо него открытый? nouveau вроде как в сисчтеме есть, но как его заставить работать вместо драйвера от nvidia?

★★★★★

Ответ на: комментарий от pyometra

удаляешь блоб, выполняешь
yast sysconfig set NO_KMS_IN_INITRD=no

ну нужно ядро как можно более свежее, более свежую месу, и то не факт что заведеться, с ферми вообще пока туго, карты серий постарше работают более мение.

Novell-ch ★★★★★ ()
Ответ на: комментарий от pyometra

Ты закрытый ставил пакетом? Если да, просто удали пакет и установи пакет с тем драйвером, который нужен.

Если устанавливал из файла .run - запусти его же с клучом --uninstall

Nxx ★★★★★ ()

Да, и KMS надо включить в опциях ядра для noveau.

Nxx ★★★★★ ()

а разреши полюбопытствовать, что за модель карты у тебя, что ты с такой легкостью отказываешься от блоба в пользу нуво? 3D устраивает или в нём нет необходимости?

science ★★☆ ()
Ответ на: комментарий от science

у меня после обновления кед до 4.7.3 плазма падает пять раз в час. хочу попробовать нуво как будет себя вести. карта GTX 560. а что даёт 3D вообще? я просто далёк от этого всего.

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

на GTX 560 нуво будет неюзабельно, так что даже не пытайся. жди как минимум 3.3 ядро.
хочешь проверить запусти мой gears on gallium таже суся, только со всем новым для откртых дров, но лично даже со всем свежайшим моя gt520 аппаратно 3д не крутит, только через софтварный llvmpipe.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

отбля. просто постоянно падающая плазма - это жуть. панель, ездящая по всему монитору после падения бесит. кстати графика с нуво не заводится- говорит драйвер не активен. нужны ещё какие-то действия для активации нуво? ядро 2.6.37.6-0.9-desktop.

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

> у меня после обновления кед до 4.7.3 плазма падает пять раз в час.

Врядли драйвер на это повлияет... Такова архитектура плазмы - падучая.

Попробуй откатить версию КДЕ, ты, кстати, из какого репозитория ставил? Возможно, у тебя несовместимые плазмоиды или еще что-то.

Nxx ★★★★★ ()
Ответ на: комментарий от pyometra

> удалил, но теперь не запускается графика

Ну а пакет с нужным драйвером стоит? Попробуй переустановить пакет и проверь, есть ли файл /etc/X11/xorg.conf - по идее он не оязателен, его можно попобовать удалить.

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

Попробуй откатить версию КДЕ, ты, кстати, из какого репозитория ставил? Возможно, у тебя несовместимые плазмоиды или еще что-то.

из KDE:Release:47

плазмоиды не использую вообще.

pyometra ★★★★★ ()
Ответ на: комментарий от Nxx

Попробуй переустановить пакет и проверь, есть ли файл /etc/X11/xorg.conf - по идее он не оязателен, его можно попобовать удалить.

сейчас попробую.

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

дает то что 3д работае, игры, эффукты типа куб и прочее, тоесть то для чего совбственно видеокарта и нужна,
2.6.37.6 - nouveau этого ядра ничего незнает о карте GTX 560, даже с ядром из opensuse 12.1 не будет работать, так что сидите на драйвере nvidia

Novell-ch ★★★★★ ()
Ответ на: комментарий от pyometra

sudo nano /etc/X11/xorg.conf.d/50-device.conf

В секции «Device» поменяй драйвер на

Driver «noveau»

Nxx ★★★★★ ()
Ответ на: комментарий от pyometra

можно также создать xorg.conf командой Xorg -configure и внутри этого файла прописать драйвер noveau.

Но главное - убедись, что у тебя modeset включен. Nvidia не запускается с ним, а noveau - без него.

Nxx ★★★★★ ()
Ответ на: комментарий от Novell-ch

2.6.37.6 - nouveau этого ядра ничего незнает о карте GTX 560, даже с ядром из opensuse 12.1 не будет работать, так что сидите на драйвере nvidia

это печально. если так, то придётся ждать обновок кед или пользовать как раньше опенбокс.

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

>у меня после обновления кед до 4.7.3 плазма падает пять раз в час. хочу попробовать нуво как будет себя вести. карта GTX 560. а что даёт 3D вообще? я просто далёк от этого всего.

Что-то неладно в консерватории. У меня тоже GTX 560, nvidia blob и KDE 4.7.3, которым я правда не пользуюсь (т.к. работать в этом Г невозможно, предпочитаю KDE3), но пользуется жена, и часами бывает засиживается, но ни разу не жаловалась на какие-либо проблемы (а если-бы они были — я узнал-бы об этом первый через две секунды).

anonymous ()
Ответ на: комментарий от pyometra

>а вот это уже интересно

Да, обычно вроде, — всю жизнь nvidia покупаю и проприетарные драйвера ставлю (не из дистрибутива) — никогда в SuSE, Slackware & Co, и Crux/Arch никаких проблем не было.

anonymous ()
Ответ на: комментарий от pyometra

> до 4.7.3 не падала плазма ни разу, ни на 4.6, ни на 4.7.2

Вариант откатиться не рассматриваешь?

Кстати, под новым пользователем как?

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

Вариант откатиться не рассматриваешь?

в новых кедах сильно много вкусностей для отката.

Кстати, под новым пользователем как?

это попробую.

pyometra ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.