LINUX.ORG.RU

[Arch] Обновился pacman, поломался yaourt


0

0

САБЖ!

При обновлении pacman до версии 3.4.0 yaourt после синхронизации БД выплёвывает следующее:

package-query: error while loading shared libraries: libalpm.so.4: cannot open shared object file: No such file or directory

Аналогично с запросом в AUR.

Откат pacman*а обратно к версии 3.3.3 спасает, но всё таки хотелось бы знать суть проблемы и методы её решения.

Гугл крайне не многословен на эту тему =(

как временный костыль можешь софтлинк libalmp.so.4 сделать...

izmena ()

Зато pacman -U теперь нормально сам может замещаемые пакеты удалять. Не прошло и года, как говорится...

ostin ★★★★★ ()

скачай PKGBUILD package-query, сделай makepkg -i и потом обновляй yaourt'ом все

madgnu ★★★★★ ()

Arch - это такая лотерея - «не было печали, апдейтов накачали».

isden ★★★★★ ()
Ответ на: комментарий от isden

Кстати да. После вчерашнего апдейта поломался аплет часов в гноме. Снашал мозг часа полтора-два. От нехрен делать запустил на обновление. Он подтянул то, что почему-то не дотянул с первого раза и всё заработало. Но этот случай и вот с yaourt'ом у меня були по-моему единственные. Что-то жгёт ставка...

kuralesov ()

А не хило то апдейтов вышло. Уже качаю.

Zodd ★★★★ ()
Ответ на: комментарий от isden

> Arch - это такая лотерея - «не было печали, апдейтов накачали».
Yaourt - сторонняя поделка, в репозитории ее нет.

metar ★★★ ()
Ответ на: комментарий от metar

Зато есть слово Arch, для некоторых как красная тряпка для быка.

vadik ★★ ()
Ответ на: комментарий от ostin

и еще зависимости подтягивать, вот это вообще здорово :)

madgnu ★★★★★ ()
Ответ на: комментарий от madgnu

Ох щиииии (тут должен быть смайл, почёсывающий затылок). Надо бы почаще то туда заходить =) Спасибо.

Правда сайт сейчас в дауне...

kuralesov ()

Первая поломка зависимости за месяц использования, и то в стороннем пакете, да и решилась простым обновлением сломанного пакета. Неплохо после Генты.

anonymous ()

Я собрал package-query-git из AUR, не каких ошибок.

n4ela ()
Ответ на: комментарий от snoopcat

Яндекс и по-моему немецкие. В чём профит именно французских?

kuralesov ()

Имхо зря отвечали йэсом на предложение сперва обновить пакман, обновлять надо было всё скопом за раз

Hokum ☆☆☆☆ ()

Сделал sudo pacman -Syu, йогурт починился =) ЗЫ зеркало от яндекса

zlordus ()
Ответ на: комментарий от vadik

Они просто завидуют черной завистью. А большинство из них видят линукс в окошке пуtty.

На самом деле package-query обновился практически сразу за pacman.

commit ()
Ответ на: комментарий от kuralesov

>Яндекс
ссзб жэ.
там недокачанные пакеты - это норма, привыкайте.

в чем профит

а в том, что это не яндекс, т.е. апдейты приходят быстро и стабильно

snoopcat ★★★★★ ()
Ответ на: комментарий от commit

Кстати - да. Даже из AUR-а собирать не пришлось, главное, чтоб французкий реп был подключен.

vadik ★★ ()
Ответ на: ЗАРАБОТАЛА!!! от kuralesov

А теперь сделай yaourt -S bauerbill pacman-color и можешь выкинуть свой yaourt.

Hetor ()
Ответ на: комментарий от Hetor

А как сделать, что бы bauebill выводил список в цвете pacman-color?

trinimak ()
Ответ на: комментарий от trinimak

Если список - это вывод всяких -Ss, то вряд ли это возможно без редактирования исходников Powerpill (он на perl'e). А жаль.

Hetor ()
Ответ на: комментарий от Hetor

Вот же:

--pacman-bin <path>
        [Powerpill option]
The path to the pacman binary or an equivalent, such as pacman-color.

Только когда я ввожу:
powerpill --pacman-bin /usr/bin/pacman-color
ошибка: не задана операция (для справки используйте -h)

не пойму в чём дело.

trinimak ()
Ответ на: комментарий от trinimak

Ну так надо powerpill/bauebill --pacman-bin /usr/bin/pacman-color -Syu, например. Но лучше PacmanBin прописать в конфиг, однако даже это цветным вывод -Ss не сделает.

Hetor ()
Ответ на: комментарий от kuralesov

Что именно не помогло? У меня-то обновилось так без проблем :)
Хотя, яндех это да, мало ли что там с актуальностью бывает.

Hokum ☆☆☆☆ ()
Ответ на: комментарий от Hokum

Как раз всё скопом за раз и не помогало. Яндех отрубил. Так же немецкое зеркало поменял на французское т.к. его тут гляжу очень сильно пиарят...

kuralesov ()
Ответ на: комментарий от kuralesov

Интересно, как так получилось. Выходит, что либы обновились, а package-query - нет?

Hokum ☆☆☆☆ ()
Ответ на: комментарий от Hokum

package-query ведь идёт из AUR. А при обновлении всего и сразу происходит обновление сначала пакетов из так сказать официальных репозиториев, в том числе и pacman, а уж потом пакеты из AUR. Вроде как-то так. Странно только что после обновления pacman'а он мне ошибку не выдавал, но и не выдавал обновление для package-query. В общем, полтергейц какой-то...

kuralesov ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.