LINUX.ORG.RU

skype - не работает микрофон


0

0

Debian Squeeze: kernel 2.6.23-15, alsa 1.0.23. Arecord нормально пишет, aplay нормально воспроизводит. Но в скайпе микрофон не работает. Если кому-то звоню, меня не слышат. Если звоню на эхо сервис echo123, говорю что-то, после второго звукового сигнала по идее должно воспроизводится то что я наговорил, но вместо этого робот почти сразу говорит стандартную фразу - «Если вы смогли прослушать сообщение...». Что это может быть?

 
$ arecord -l 
**** List of CAPTURE Hardware Devices **** 
card 0: VT82xx [HDA VIA VT82xx], device 0: VT1708B Analog [VT1708B Analog] 
  Subdevices: 2/2 
  Subdevice #0: subdevice #0 
  Subdevice #1: subdevice #1 
card 0: VT82xx [HDA VIA VT82xx], device 1: VT1708B Digital [VT1708B Digital] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 
 
$ cat /proc/asound/cards 
 0 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx 
                      HDA VIA VT82xx at 0x9fffc000 irq 17 
 
$ lsmod|grep snd 
snd_pcm_oss            28671  0 
snd_mixer_oss          10461  1 snd_pcm_oss 
snd_hda_codec_via      19285  1 
snd_hda_intel          16683  1 
snd_hda_codec          46002  2 snd_hda_codec_via,snd_hda_intel 
snd_hwdep               4054  1 snd_hda_codec 
snd_pcm                47214  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec 
snd_seq                35375  0 
snd_timer              12258  2 snd_pcm,snd_seq 
snd_seq_device          3673  1 snd_seq 
snd                    34339  11 snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device 
soundcore               3450  1 snd 
snd_page_alloc          5001  2 snd_hda_intel,snd_pcm 

А если запустить alsamix и убрать в нем до нуля один из каналов микрофона?

Vit ★★★★★ ()
Ответ на: комментарий от no-dashi

>IP «белый» или за маскарадом сидишь?

Когда это маскарад останавливал скайп ? :))

sS ★★★★★ ()
Ответ на: комментарий от no-dashi

дело не в роутинге, на 2.6.27 всё работало. Но там в ядре ещё не было snd_hda_codec_via. Грешу пока на него, других мыслей нет. Пробовал более старую алсу через LD_PRELOAD, результата не дало. Если выставить неправильный канал для микрофона в настройках скайпа, то воспроизведение того что я говорил работает, но вместо звука скрип и шум - то есть звук от меня до сервера идёт нормально, проблема локальная.

alex_custov ★★★★★ ()
Ответ на: комментарий от alex_custov

Вернутся на .27 не?

PS: у самого была похожая ситуация. Долго бился; в итоге накатил ядро + alsa utils поновее и все пучком

ZuBB ★★★★★ ()
Ответ на: комментарий от ZuBB

есть причины из-за других драйверов остаться на .32

alex_custov ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.