LINUX.ORG.RU

Upgrade системы amd64

 ,


0

1

После длительных манипуляций с обновлениями выяснил, что моё железо полноценно работает только с одним ядром 5.8.0-43 (Ubuntu Focal 20.04 LTS, ASUS X555L, AMD64). Проблемы с WiFi/Bluetooth на плате Mediatek MT7630E. Пробовал ядра 5.12, 5.13, но все безуспешно (не находит требуемые header-файлы), либо не работает и не переустанавливается Bluetooth, либо целиком WiFi (на плате эти функции интегрированы). Сейчас пытаюсь удалить все установочные (и иные) файлы этих неиспользуемых версий установленных ядер, делаю это, например, по гайду https://losst.ru/kak-udalit-starye-versii-yadra-v-ubuntu через Synaptic (буду пытаться, пока достаточного опыта нет), и задаюсь вопросом:

как «жить» дальше, как и когда обновляться, удастся ли когда-либо обновить систему к новой LTS 22.04?

В кратце история «болезни»: однажды не смог установить PgAdmin4 к Postgres, репозиторий оказался не рабочим или что-то сделал не так. В итоге перестал работать Software & Updates, просто не открывался вообще. Не нашел никаких способов и пришлось достать LiveUSB, с которого начинал, и установить систему поверх (без удалений и форматирования). Но включил автообновление, и в итоге получил 5.13, в которой железо отказывалось работать.

Теперь загружаюсь через Дополнительные опции загрузки с выбором своего рабочего ядра.

Прошу помочь советами: как правильно проводить обновления в Ubuntu Linux, особенно, через встроенный Software Updater, автозапуск которого просто не нахожу возможности отключить.


Ответ на: комментарий от mkaro

Мои темы с BT:

KDE Bluetooth

Bluetooth ноутбук ASUS

Bluetooth ноутбук ASUS (комментарий)

Последнюю установку делал так:

newbtfix-4.15-1

Ubuntu 4.15 bluetooth source code patched with https://bugzilla.opensuse.org/attachment.cgi?id=770190

Credit goes to Takashi Iwai for the patch

Bluetooth: hci0: don’t support firmware rome 0x11020000

Should fix Ubuntu Bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1764645

To use

sudo apt install git build-essential dkms

git clone https://github.com/jeremyb31/newbtfix-4.15.git

sudo dkms add ./newbtfix-4.15

sudo dkms install btusb/4.0

Reboot

Выглядит все так: https://askubuntu.com/questions/1271348/bluetooth-wasnt-identifying-any-of-my-devices-now-not-working-at-all

mkaro ()
Ответ на: комментарий от mkaro

После ребута, но не с первого раза, BT поднялся.

Первый ребут не пошел. Висим. Дефолт. Второй - норма. BT сразу в On с последним активным соединением.

mkaro ()
Ответ на: комментарий от mkaro

В общем, похоже, мне спать нельзя)), долго точно. Надо работать. Решено.

mkaro ()
Последнее исправление: mkaro (всего исправлений: 1)
Ответ на: комментарий от Dimez

+++

Что делать, если apt update дает ошибку, как здесь:

E: The repository 'https://download.sublimetext.com apt/stable/ InRelease' is not signed.

Что делать с репозиторием?

mkaro ()
Ответ на: комментарий от mkaro

Либо найти ключ и положить его в /etc/apt/trusted.gpg.d/ (или запросить его apt-key adv --keyserver keyserver.ubuntu.com --recv ключ), либо удалить репозиторий.

Dimez ★★★★★ ()
Последнее исправление: Dimez (всего исправлений: 2)
Ответ на: комментарий от Dimez

Нужно ли всякий раз нажимать Update в <Software & Updates> после каждой правки в разделе Other Software, который предлагается программой в «принудительно-добровольном» порядке)?

mkaro ()
Ответ на: комментарий от mkaro

Это я не знаю. У меня лично все автоапдейты отключены, обновляюсь руками из консоли apt update && apt dist-upgrade

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Даже если тебе случайно прилетит новое ведро, запиненная версия останется

Текущее ядро в ubuntu не подпадает под autoremove.

Вот только при загрузке с новым ведром оно перестаёт быть текущим.

LamerOk ★★★★★ ()
Ответ на: комментарий от LamerOk

Вот только при загрузке с новым ведром оно перестаёт быть текущим.

Ты потерял нить разговора и закольцевал его :) Нового ядра не будет без метапакета, ибо его удалили.

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Штуковина у меня такая выходит. Спать ноут отказывается напрочь, вернее, после сна пропадает не только BT, но и клава, мышь, если USB вытащил, чтобы не разбудить случайно. Нужна сразу перезагрузка, тогда оживет. Что за ерунда.

mkaro ()
Ответ на: комментарий от mkaro

Ну и dmesg надо после выхода из сна. Хотя там наверняка ошибки ACPI, которые обычно как раз и лечатся обновлением биоса.

Dimez ★★★★★ ()

не смог установить PgAdmin4 к Postgres

Для подобных тулзов, несовместимых с твоей системой, лучше играть в докере, где ты можешь кучу ядер перепробовать не сломав систему

как правильно проводить обновления в Ubuntu Linux, особенно, через встроенный Software Updater

ИМХО, лучше не использовать синаптик никогда :) есть же стабильно работающий apt

Aswed ★★★★★ ()
Ответ на: комментарий от Aswed

OK. Пока все работает, после чистки и наладки… pg почему-то установился 12-й. PgAdmin4 в норме.

Software Updater предлагает обновиться, в том числе, Postgres до версии 14. Вот не знаю, доверяться или нет.

PostgreSQL C client library
---------------------------
Changes for libpq5 versions:
Installed version: 12.9-0ubuntu0.20.04.1
Available version: 14.2-1.pgdg20.04+1+b1

This update does not come from a source that supports changelogs.
mkaro ()
Ответ на: комментарий от mkaro

Вопрос странный. Если тебя устраивает для твоих эксперементов pg12, то используй его. Зачем тебе обновление? Если нужно прям 14, то запусти ты его в докере, это делается одной строчкой докерфайла. У тебя же все равно не сервер, а десктоп

Aswed ★★★★★ ()
Ответ на: комментарий от mkaro

Докер появился 9 лет назад. Он уже давно не новый.

Aswed ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)