LINUX.ORG.RU

Gentoo, при загрузке инита не проверяется f2fs, как это починить?

 , ,


0

2

При загрузке инита вот такой вывод:

* Checking local filesystems  ...
fsck.ext4: Bad magic number in super-block while trying to open /dev/mmcblk1p2
/dev/mmcblk1p2: 
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

/dev/mmcblk1p2 contains a f2fs file system
 * Operational error
Насколько я понял система пытается чекнуть раздел, что разумно, отказываться от проверок я не хочу, но
opipcplus ~ # file -s /dev/mmcblk1p2
/dev/mmcblk1p2: F2FS filesystem, UUID=631f24f9-d050-4c01-a7a9-07dbd063a1d7, volume name ""
Надо чекать не e2fsck, а fsck.f2fs, что и где исправить, чтоб проверка происходила корректно?

★★

Ответ на: комментарий от burato

я пробовал писать f2fs, но он не принимает эту запись

https://www.funtoo.org/F2FS_Install_Guide
https://forum.manjaro.org/t/how-well-does-the-architect-manage-fstab-for-f2fs...
А у людей работает.
Может ты что-то с параметрами монтирования там накосячил? Проверь. Здесь все есть:
https://www.kernel.org/doc/Documentation/filesystems/f2fs.txt

пришлось ext4

Поэтому ее и проверяют как ext4.

надо научить его как то

Указав не ту фс точно ничего не добьёшься. Смотри параметры монтирования в fstab. Наверняка там что-то не так.

imul ★★★★★ ()
Ответ на: комментарий от burato

но он не принимает эту запись, не умеет

Что значит не умеет? какую ошибку выдаёт? телепаты в отпуске

пришлось ext4

Это просто ГЕНИАЛЬНО. И как оно по-вашему вообще должно работать? Подозрительно, что вообще монтируется. :-)

BattleCoder ★★★★★ ()
Ответ на: комментарий от burato

я пробовал писать f2fs, но он не принимает эту запись, не умеет, пришлось ext4

*facepalm*

Взял головной убор и надел его себе на х^W руку, а потом еще и удивляется - а чо не так?

sys-fs/f2fs-tools хоть установлены?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от burato

Укажи там f2fs временно и попробую в самой системе так:

mkdir /test
mount -o norecovery /dev/mmcblk1p2 /test

Некоторые ФС можно смонтировать дважды, хз как насчет с f2fs. При norecovery там автоматом ставится ro, так что файловую систему ты себе не упорешь.

Если там монтирование не идет, значит какая-то шляпа либо с самим бинарем mount, либо с f2fs-tools

Если всё монтируется успешно - проблема в openrc и/или baselayout

А, и еще, чему у тебя там rc_parallel равен в /etc/rc.conf ?

А то вот тут пишут, что если он yes, будет нехорошо

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 2)
Ответ на: комментарий от burato

Gentoo Wiki пишет

Troubleshooting When using f2fs as rootfs fsck fails on boot. Solutions are either disabling fsck in /etc/fstab (setting the last number to 0) or enabling the force-flag for fsck in /etc/conf.d/fsck. See bug #671786.

Напиши

/dev/mmcblk1p2          /               f2fs          defaults        0 0

И попробуй загрузиться.

Mixa ()