LINUX.ORG.RU

Как правильно поменять тему XFCE4 4.12

 , ,


0

1

Всем привет. Подскажите, пожалуйста, как правильно менять темы в debian buster xfce4 4.12? Я прочел, что нужно создать в домашнем каталоге $HOME/.local/share/themes и туда копировать тему. Я скачал несколько тем с сайта gnome-look.org, разархивировал и положил темы в themes. В настройках внешнего вида темы появились, но когда я их применил (выбрал тему в настройках общего вида и настройках оконного менеджера), то поменялось как-то половинчато. Окна и содержимое поменяли вид, а панели xfce4 и меню не поменялось. В панели стоит настройка использовать общесистемную тему. Я пробовал перезагружаться, но это не помогло. Что я делаю не так? Кстати, с темами, которые уже стояли в системе, такой проблемы нет. Все меняется сразу.

Панель в этой версии ещё на ГТК2, в теме просто может не быть оформления для этой версии. Надо проверять, есть ли в каталоге темы подкаталог для ГТК2.

Qathos ()
Ответ на: комментарий от Qathos

Есть. Вот, например, тема Nordic

Nordic/
Nordic/kde
Nordic/kde/colorschemes
Nordic/kde/kvantum
Nordic/kde/kvantum/Nordic-Darker
Nordic/kde/kvantum/Nordic
Nordic/kde/look-and-feel
Nordic/kde/look-and-feel/contents
Nordic/kde/look-and-feel/contents/previews
Nordic/kde/look-and-feel/contents/splash
Nordic/kde/look-and-feel/contents/splash/images
Nordic/kde/konsole
Nordic/kde/aurorae
Nordic/kde/aurorae/Nordic
Nordic/xfwm4
Nordic/xfwm4/assets
Nordic/Art
Nordic/assets
Nordic/.git
Nordic/.git/hooks
Nordic/.git/info
Nordic/.git/branches
Nordic/.git/objects
Nordic/.git/objects/info
Nordic/.git/objects/pack
Nordic/.git/refs
Nordic/.git/refs/remotes
Nordic/.git/refs/remotes/origin
Nordic/.git/refs/heads
Nordic/.git/refs/tags
Nordic/.git/logs
Nordic/.git/logs/refs
Nordic/.git/logs/refs/remotes
Nordic/.git/logs/refs/remotes/origin
Nordic/.git/logs/refs/heads
Nordic/gtk-3.0
Nordic/gtk-3.0/apps
Nordic/gtk-3.0/widgets
Nordic/gnome-shell
Nordic/gnome-shell/extensions
Nordic/gnome-shell/assets
Nordic/gtk-2.0
Nordic/gtk-2.0/assets
Nordic/gtk-2.0/apps
Nordic/metacity-1
Nordic/src
Nordic/src/wm
Nordic/src/gtk3
Lebadem ()

Скорее всего, какого-нибудь GTK2 движка не хватает (pixbuf / murrine/ и т.д.).

А вообще лучше ставить что-нибудь дистрибутивное (arc-theme, например), тогда все зависимости подтянутся автоматом.

barti_ddu ()