LINUX.ORG.RU

Установка php 5.6 палаллельно php 7 на Debian 9

 ,


0

2

Привет!
Поднял дома сервер на Debian 9.
Поставил php7.
Вроде как можно поставить другую версию php (5.6) и по необходимости переключаться с одной на другую (php как модуль apache).
Но пробую ставить php 5.6, ругается «Нет подходящей версии для libapache2-mod-php5
Не удалось применить некоторые действия, прерываем работу»
Что ему не нравится?

Что ему не нравится?

Версии/зависимости пакетов?

А вообще для зоопарка версий или docker/lxc, или ручная сборка.

gwinn ★★★★ ()

К релизу в девятке 5.6 выпилили, но одно время в репах был и 7.0 и 5.6, нормально работали вместе.
Лично я завёл под старую пыху отдельный lxc-контейнер с debian 9 и васянским репозиторием, но я не знаю что там с апачёвым модулем, у меня php-fpm

MrClon ★★★★★ ()
Ответ на: комментарий от gwinn

Docker не стал, там только 64-битная версия, а я поставил Deb9 i386, думал, старое железо.
Вчера все-таки, переставил на Deb8 64, он как-то ближе.

ctyz2068 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.