LINUX.ORG.RU

Помогите с настройкой отображения языка в arch

 , , ,


0

2

Я вроде бы настраивал локали. Если нужны будут содержания каких-либо конфигов, я скину.

  • В xterm по умолчанию стоит ansi_x3.4-1968 и соответственно надписи на русском языке отображаются в виде "?????". Можно выбрать unicode UTF-8, но не знаю, как задать его по умолчанию.
  • LibreOffice некорректно отображает название документа на русском, хотя содержание документа отображается корректно.

Подскажите, пожалуйста, что надо настраивать, куда смотреть. Я пробовал менять различные настройки, в основном локали, но безуспешно. Буду признателен.


В xterm можно в настройках задать encoding. С libreofice так и не разобрался ещё.

Hi ()

Насколько я помню, арч - потомок слаки. И, понимать и действовать надо так:
В /etc/rc.d/rc.font напиши ruwin_ctrl-UTF-8
А в /etc/profile.d/lang.sh
#export LANG=ru_RU.UTF-8
И фсё.

cadaber ()
Ответ на: комментарий от radg

У меня не получается настроить по арч вики, поэтому я прошу помощи. Вот как сейчас у меня настроено:

  • В /etc/locale.gen раскоментированны en_US.UTF-8 UTF-8 и ru_RU.UTF-8 UTF-8
  • # sudo locale-gen
    Generating locales...
    en_US.UTF-8... done
    ru_RU.UTF-8... done
    Generation complete.
  •  $ cat /etc/locale.conf
    LANG=ru_RU.UTF-8
    LC_COLLATE=ru_RU.utf8
    LC_COLLATE=en_US.utf8
  • $ locale -a
    C
    POSIX
    en_US.utf8
    ru_RU.utf8
  • Настраивал vconsole.conf так:
    # localectl set-keymap ruwin_alt_sh-UTF-8
    $ cat /etc/vconsole.conf
    KEYMAP=ruwin_alt_sh-UTF-8
  • $ localectl status
    System Locale: LANG=ru_RU.UTF-8
    VC Keymap: ruwin_alt_sh-UTF-8
    X11 Layout: ru,us
    X11 Model: pc105
    X11 Options: terminate:ctrl_alt_bksp,grp:shifts_toggle,grp_led:scroll
  • Настройка автостарта openbox'а (~/.config/openbox/autostart) содержит следующие строки для раскладки: # keyboard launchpad helder setxkbmap -layout us,ru -variant -option grp:alt_shift_toggle,terminate:ctrl_alt_bksp &

Если для решения моей проблемы нужны какие-либо ещё выводы, дайте знать, я скину.

Hi ()
Ответ на: комментарий от Hi

Кажется, что в xterm указание кодировки это костыль. Возникают ошибки использвания этой кодировке. В процессе настройки кодировке, перестали вводится буквы в slim'е. Пришлось настроить автологин. Пока проблема со slim'ом не решена.

Hi ()
Ответ на: комментарий от bigov

Если ставить оркаль так

# localectl set-locale LANG=en_US.UTF-8
, то будет только одна строка. На самом же деле это ничего не меняет, я пробовал и так и иначе с прописыванием
LC_MESSAGES=ru_RU.UTF-8

Hi ()
Ответ на: комментарий от Hi

не надо умничать. Просто сделай по пунктам точно как написано в справке, после этого перезагрузи тачку и будет тебе счастье.

Я в этом году уже три разных тачки настроил по этому описанию - все замечательно работает.

bigov ()
Ответ на: комментарий от bigov

Я не умничаю. Я делал по этому описанию и у меня ничего не получилось. Сейчас сделаю всё и скину вывод, что бы не было сомнений в моих словах. Либо я что-то не так каждый раз настраиваю, но я не понимаю что. Как мне кажется, окали перераспределяет другой файл, но я в этом не уверен.

Hi ()
Ответ на: комментарий от bigov

Думаю, что у меня перераспределяются настройки потому, что:

У меня в locale.conf

ANG=ru_RU.UTF-8
LC_COLLATE=ru_RU.utf8
LC_COLLATE=en_US.utf8
LC_MESSAGES=ru_RU.UTF-8

А вот что выводит $ locale

LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Hi ()
Ответ на: комментарий от Hi
#!/bin/sh

if [ -z "$LANG" ]; then
  if [ -n "$XDG_CONFIG_HOME" ] && [ -r "$XDG_CONFIG_HOME/locale.conf" ]; then
    . "$XDG_CONFIG_HOME/locale.conf"
  elif [ -n "$HOME" ] && [ -r "$HOME/.config/locale.conf" ]; then
    . "$HOME/.config/locale.conf"
  elif [ -r /etc/locale.conf ]; then
    . /etc/locale.conf
  fi
fi

LANG=${LANG:-C}
export LANG
[ -n "$LC_CTYPE" ]          && export LC_CTYPE
[ -n "$LC_NUMERIC" ]        && export LC_NUMERIC
[ -n "$LC_TIME" ]           && export LC_TIME
[ -n "$LC_COLLATE" ]        && export LC_COLLATE
[ -n "$LC_MONETARY" ]       && export LC_MONETARY
[ -n "$LC_MESSAGES" ]       && export LC_MESSAGES
[ -n "$LC_PAPER" ]          && export LC_PAPER
[ -n "$LC_NAME" ]           && export LC_NAME
[ -n "$LC_ADDRESS" ]        && export LC_ADDRESS
[ -n "$LC_TELEPHONE" ]      && export LC_TELEPHONE
[ -n "$LC_MEASUREMENT" ]    && export LC_MEASUREMENT
[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
man_of_motley ★★ ()
Ответ на: комментарий от Hi

Так, давай по-порядку: - на каком оборудовании твой линух (виртуалка, железо, платформа) - какой гуй (окружение рабочего стола) у тебя - какой сервер графики (X11 или что-то другое) - как ты подключаешься к своему арчу - удаленно терминал, рабочий стол, виртукалка типа VNC, прямая консоль.

Это все влияет. Давай разберемся.

bigov ()

Решено

Всем спасибо за помощь.

По всей видимости проблема была в slim. Вот как я её решал:

  • Удалил slim, поставил LightDM.
  • Локали настроил следующим образом:
    $ cat /etc/locale.conf
    LANG=en_US.UTF-8
    LANGUAGE=ru:en
    LC_TIME=ru_RU.UTF-8
    LC_COLLATE=en_US.UTF-8
    LC_COLLATE=ru_RU.UTF-8 
  • Для переключения раскладки в LightDM отредактировал настройки xorg, первым языком поставил en и переключения раскладок забиндил на альт-шифт, вот вывод:
    $ cat /etc/X11/xorg.conf.d/00-keyboard.conf
    # Read and parsed by systemd-localed. It's probably wise not to edit this file
    # manually too freely.
    Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "us,ru"
    Option "XkbModel" "pc105"
    Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle,grp_led:scroll"
    EndSection 

После того как у меня всё заработало корректно, решил вернуть slim. После установки slim'а все изменились на POSIX. Теперь пользуюсь LightDM, slim удалил.

Hi ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.