LINUX.ORG.RU

Tmux «съезжает» при переходе в подкаталоги при использовании zsh.

 ,


0

1

Происходит это если перейти в директорию с достаточно длинным путём. Нотариально заверенный скринкаст прилагается:
https://www.youtube.com/watch?v=chQ_EAq75JE
От темы zsh не зависит, но в баше такой фигни нет. Подозреваю, что дело в отображении CWD в статусной строке тмукса, которое почему-то раскукоживает его интерфейс. В принципе, меня устроит возможность это отображение отключить, но я нашёл только способ его включить, а я этого не делал, оно само.
tmux.conf:

unbind C-b
set -g prefix `
set -g base-index 1
set -g default-terminal "xterm-256color"
set-window-option -g utf8 on
bind-key a send-keys `
bind-key ` send-prefix
### Set colors
set-option -g status-bg colour235
set-option -g status-fg colour255
set-option -g window-status-current-fg colour000
set-option -g window-status-current-bg colour250
set-window-option -g xterm-keys on

★★★★★

У меня заголовки окон tmux обрезаются и скрываются, если не влезают.

Black_Roland ★★★★ ()
Последнее исправление: Black_Roland (всего исправлений: 1)
Ответ на: комментарий от Black_Roland

Спасибо, set -g status-right '%Y-%m-%d %H:%M' решило проблему.

Axon ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.