LINUX.ORG.RU
ФорумGames

Опакетьте, пожалуйста, oolite 1.88

 


0

1

2018-10-23 зарелизилась версия 1.88

Но опакетить её нет никакой возможности - сообщество пятнадцатый год ищет мейнтейнера: https://bugs.gentoo.org/106890

@AITap, @alcoholic, @AMDmi3, @AndreyU, @andreyu, @anonym43, @atsym, @basp, @batekman, @buratino, @ChekPuk, @cPunk, @domenick, @eagleivg, @ha, @feofan, @FiXer, @gamecoder, @gremlin_the_red, @Gorthauer, @hobbit, @IvanR, @Jameson, @JaneDoe, @karton1, @kim-roader, @KroArtem, @Led, @lnx, @Marmirus, @MEZON, @nloshka, @papay, @Polugnom, @Rastafarra, @redgremlin, @Red_Lion, @registrant, @rexadecimal, @Rumata, @rumata, @Sargan, @seventh, @sith, @skiminok1986, @Slavaz, @slipped_on_blade, @slovazap, @Suntechnic, @stanson, @tailgunner, @toney, @trycatch, @vovans, @wakuwaku, @X286, @Xenius, @ysagat, @yuko

не хотите ли вы опакетить эту программу? Вот и я тоже не хочу.

в багах debian написано, почему она снята с маинтайнтства. я подробностей не помню.

в debian играю с run.файла. в openbsd играю в старую добрую 1.73.4, которая там :)

buratino ★★★★★ ()

а скока ты готов за это заплатить

Harald ★★★★★ ()

Запускай Oolite-1.88_x64.exe под вайном, чо ты.

zendrz ()
Ответ на: Суть причины - ему лень от Einstok_Fair

I am orphaning the oolite package. Upstreams embeds an outdated copy of a library dependency [α], for sensible reasons summarized at [β]. Building in a way compatible with Debian standards, if even possible, would require much more efforts than I can afford.

[α] https://bugs.debian.org/863788

[β] https://github.com/OoliteProject/oolite/issues/271

buratino ★★★★★ ()
Ответ на: комментарий от buratino

Я так и процитировал. Вторая строчка в твоём комментарии такая же как в моём. Якобы твой ответ дополняет и углубляет, и всё «делает ясным», но нет. Мейнтенерам просто лень подпатчить игру для работы с другой версией движка. И они приводят всякие разные отмазки. Я тоже так умею.

Einstok_Fair ★★☆ ()
Последнее исправление: Einstok_Fair (всего исправлений: 2)

Ничивонипонил. Есть оно в ауре, у меня собранная стоит. Не помню проблем при сборке. А как у вас там в генте не знаю. И знать не хочу. Но смешит тот факт, что мейнтейнер Дебьяна отказался поддерживать потому что прога зависит от устаревшей библиотеки. Тоесть, даже для дебьяна она устаревшая? Прикольно.

ChekPuk ★★ ()
Ответ на: комментарий от Einstok_Fair

Мейнтенерам просто лень подпатчить игру для работы с другой версией движка.

Это дже оупенсорс, тебе надо - вот и патч сам. Напиши мантейнеру, найди спонсора и вперед, к звездам. Ты воспринимаешь мантейнеров как каких-то работников, которые тебе что-то там должны.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от ChekPuk

Дебьяна отказался поддерживать потому что прога зависит от устаревшей библиотеки

Да, это нарушение Debian policy. Никто не будет разбираться в проблемах древней библиотеки. А если там еще и CVS какая-то вылезет, то вообще швах. DeadBeef не берут ровно по тем же причинам.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Да, это нарушение Debian policy

Главное, чтобы не CoC

DeadBeef не берут ровно по тем же причинам.

DeadBeef – dead o_O

CryNet ★★★★ ()
Последнее исправление: CryNet (всего исправлений: 1)

не хотите ли вы опакетить эту программу? Вот и я тоже не хочу.

Поговорим о награде.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от Einstok_Fair

Проблема, которую описали разработчики очень глубокая. Можно ради Дебьяна переписать всё и сломать совместимость со всеми дополнениями, это будет просто вин :)

Старая игра застрявшая на старом туллките, что ты хочешь?

ChekPuk ★★ ()
Ответ на: комментарий от CryNet

Он от рождения dead :)

Ещё один пример того, как проект умирает не потому что плох, а потому что его постоянно не переписывают под новые библиотеки.

ChekPuk ★★ ()
Ответ на: комментарий от ChekPuk

А как дебианопроблемы связаны с опакечиванием под генту?

lua ()
Ответ на: комментарий от Polugnom

Шутка юмора в том, что эта библиотека даже для Дебьяна старая. А то, что не принимают в Дебьян ненадёжные пакеты - это хорошо. Плохо, что пользователю не оставили возможность отстрелить себе ногу, как в ауре.

ChekPuk ★★ ()
Ответ на: комментарий от lua

А гентушники всю жизнь только или канпеляют, или ждут ебилдов, как ТС, я́ их во внимание не принимаю.

ChekPuk ★★ ()
Ответ на: комментарий от ChekPuk

А то, что не принимают в Дебьян ненадёжные пакеты - это хорошо

А что, «старый» = «ненадёжный»? Он там что-то сломает, если будет только для одного приложения?

AS ★★★★★ ()
Ответ на: комментарий от Polugnom

Ты воспринимаешь мантейнеров как каких-то работников, которые тебе что-то там должны.

Этим, кстати, многие страдают.

AS ★★★★★ ()

oolite

Хм. «Oolite is inspired by the 8-bit classic Elite». Как давно это было...

AS ★★★★★ ()
Ответ на: комментарий от AS

Ну, там, небось, секьюрити дыр накопилось, а никто не чинит.

dsxl ()
Ответ на: комментарий от buratino

Чушня какая-то. Они ж библиотеку эту старую с собой таскают, а высосанное из пальца

Upstream relies on a very old copy of the Mozilla javascript interpreter (libmozjs/spidermonkey), downloaded during the build from a private URL, without electronic signature.

вообще ни в какие ворота не лезет, потому что этот старый mozjs берётся оттуда же, откуда сама oolite. Т.е. сырцы самой oolite им не западло скачивать с «private URL», а сырцы старой mozjs оттуда же - западло? Они там теперь постоянно курят что-то, что-ли?

Stanson ★★★★★ ()

А опакетьте мне, пожалуйста, Zotero 5 в дебиане, а то он теперь зависит от тонны сторонних пакетов с npm, которые собирать DFSG-совместимым способом задолбаешься (запускать официальный бинарник в контейнере Firejail с проброшенным ~/zotero и иксами тоже ни фига не весело). Или посоветуйте другой менеждер библиографии, который будет работать и у меня на Debian oldstable, и у научрука на Windows 2008 + MSO 2010.

По теме: у меня в ~/vcs уже столько всякого ПО, которое я прямо оттуда и запускаю. Например, Ion Fury (eduke32) и wrath-darkplaces. А чем Oolite хуже? Конечно, с поддерживаемыми мэйнтейнером пакетами это не сравнится, но хотя бы скачать обновления или откатиться можно одним checkout с последующей пересборкой.

AITap ★★★★★ ()
Ответ на: комментарий от ChekPuk

и сломать совместимость со всеми дополнениями

Если они не опенсорсные, то не нужны. А если опенсорсные, их все можно пропатчить тоже.

Einstok_Fair ★★☆ ()

Если под CentOS 5/6 соберётся, могу собрать под него.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Einstok_Fair

Руки в ноги и вперёд: шлёпать мейнтейнеров огромными пачками купюр по их пухлым щёчкам.

В ином случае патчить надо самому.

Result-Code ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей