LINUX.ORG.RU

Каких программ лично вам в Линуксе не хватает?

 ,


0

6

По следам моего предыдущего поста. Возможно, я смогу восполнить пустоту в этом и займусь этим. Кто будет писать ответ, адекватно оценивайте способности одиночки, и автокады, игры и фотошопы и прочий аналогичный софт нет смысла предлагать.

Ответ на: комментарий от waker

это более секурно, чем то что ты делаешь.

как сказать: за компом дома не только я сижу, а то что я ставлю, я скачиваю только с официальных сайтов. Зато остальные ничего без моего ведома не установят (если только в свой профиль). То есть вероятность словить что-то в случае если они это скачают гораздо выше, чем на официальном сайте софтины окажется что-то вредоносное. К тому же, ну выдаёт он это предупреждение, что файл может быть небезопасен, что теперь тот же mercurial не ставить из-за этого?

Переключение между пользователями я тоже как-то делал для членов семьи, но это неудобно было, постоянно бегать между сеансами, даже просто для установки.

grem ★★★★★ ()
Ответ на: комментарий от grem

К тому же, ну выдаёт он это предупреждение, что файл может быть небезопасен, что теперь тот же mercurial не ставить из-за этого?

ты сам решаешь, что тебе ставить, а что не ставить.

дело системы предупредить, что есть вероятность, что бинарник пришел не оттуда, откуда ты думаешь.

меркуриал был взят ради скриншотов, т.к. я знал что он не подписан.

waker ★★★★★ ()
Ответ на: комментарий от grem

как сказать: за компом дома не только я сижу, а то что я ставлю, я скачиваю только с официальных сайтов. Зато остальные ничего без моего ведома не установят (если только в свой профиль). То есть вероятность словить что-то в случае если они это скачают гораздо выше, чем на официальном сайте софтины окажется что-то вредоносное.

я до сих пор не понимаю, какое отношение имеет твой способ настройки и использования венды, к тому факту что в линуксе нет вообще данной фичи.

ты таким образом пытаешься сказать лоровское «ненужно»?

waker ★★★★★ ()
Ответ на: комментарий от waker

Не то чтобы ненужно, но в том виде, в котором оно в windows, оно по факту не работает, т.к. большая часть софта всё равно подписи не имеет и получается, что это ничем не лучше отсутствия проверки: я и без предупреждений знаю, что файл снаружи всегда потенциально опасен. В случае установки из магазина приложений ситуация должна быть лучше, но и в том же debian репозитории вполне себе подписаны, разве что ключи неофициальных руками добавлять нужно.

grem ★★★★★ ()
Ответ на: комментарий от grem

Не то чтобы ненужно, но в том виде, в котором оно в windows, оно по факту не работает, т.к. большая часть софта всё равно подписи не имеет и получается, что это ничем не лучше отсутствия проверки

весь коммерческий софт подписан. васянские сборочки — да, подписи не имеют. и да, я согласен, что в винде верификация реализована не лучшим образом. в macOS намного лучше IMO. (при этом в обоих ОС оно хотя бы есть, в отличие от)

В случае установки из магазина приложений ситуация должна быть лучше, но и в том же debian репозитории вполне себе подписаны

репозитории нельзя сравнивать с магазинами приложений. в репозиториях не предусмотрена возможность публикации разработчиком своих разработок.

waker ★★★★★ ()
Последнее исправление: waker (всего исправлений: 1)

Не хватает нормального GUI_евого веб-броузера, которое пилит сообщество на гитхабе например, и нормального тулкита для гуев, который бы не болел болезнями GTK и QT, где переходы из версии в версию были бы обычными, просто циферка сменилась и всё. Этих двух вещей не хватает.

With ★★★ ()
Ответ на: комментарий от waker

сам нагуглишь, если сильно надо.

Вот, кстати, недавно хотел Visual Studio Community Edition, чтобы нужный драйвер собрать. Так оно не захотело ставиться. Гуглил, гуглил решение, но так ничего и не нагуглил. Вернее, нагуглил мнения о том, что iso для офлайн установки больше скачать нельзя.

Так что не всё можно нагуглить, даже если сильно надо.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

А там нужно обновить windows до полного актуально состояния, чтобы он имел возможность проверить вшитые сертификаты оффлайн, иначе он хотел лезть в инет и сверять.

Для msvs исошек не сделали, но онлайн установщик позволяет опциями командной строки указывать компоненты которые можно скачать для последующей установки на оффлайновой машине, только боюсь, что он тоже поставиться не сможет, если каки-нибудь обновлений не стоит для сверки сертификатов.

Возможно, старые версии доступны в msdn.

grem ★★★★★ ()
Ответ на: комментарий от grem

capture one от phase one «васянская сборочка»? кхм.

я хотел проверить, действительно ли ты не врешь, и кто-то не подписывает софт перед релизом, но эти ребята требуют регистрацию с номером телефона и real name, чтобы скачать trial.

было бы интересно увидеть пруф твоего утверждения, в виде скриншота окошка «The publisher could not be verified».

waker ★★★★★ ()
Ответ на: комментарий от waker

я хотел проверить, действительно ли ты не врешь, и кто-то не подписывает софт перед релизом, но эти ребята требуют регистрацию с номером телефона и real name, чтобы скачать trial.

было бы интересно увидеть пруф твоего утверждения, в виде скриншота окошка «The publisher could not be verified».

Я не утверждал, что он «не может быть проверен», я говорил, что выскакивает предупреждение (если запускать от пользователя), что файл из интернета и попросит подтверждение на запуск. Что странно, так это то, что для версии 9.3.0 такое предупреждение не выскакивает (он сразу спрашивает пароль администратора). Но если посмотреть в свойствах версии 10.1.2 то там тоже есть подписанный сертификат.

http://imgur.com/j1TBhIk

grem ★★★★★ ()
Ответ на: комментарий от grem

тогда я не понимаю, к чему была эта фраза:

capture one от phase one «васянская сборочка»? кхм.

насколько я понял, с этой программой все в порядке.

я никогда не видел чтобы при запуске программ выскакивал запрос пароля администратора, вероятно это происходит только из под учеток, которые не входят в группу Administrators, а такими учетками я никогда не пользовался.

waker ★★★★★ ()
Ответ на: комментарий от grem

Что странно, так это то, что для версии 9.3.0 такое предупреждение не выскакивает (он сразу спрашивает пароль администратора)

может быть ты просто для версии 9.3.0 отключил checkbox «всегда спрашивать для этого файла»? (он есть на твоем скриншоте)

waker ★★★★★ ()
Ответ на: комментарий от waker

может быть ты просто для версии 9.3.0 отключил checkbox «всегда спрашивать для этого файла»?

Вряд ли, проверил на паре подписанных файлов, которые никогда не запускал и там такое окошко не выскочило. Похоже, что именно для того файла что-то не отрабатывает. А запрос пароля это нормально, его я как раз ожидаю.

Хм, подписи есть у установщиков-экзешников, но не нашёл ни одного файла msi, который запрашивал бы подтверждение на запуск. А у них вкладки с данными о сертификате нет.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

Хм, подписи есть у установщиков-экзешников, но не нашёл ни одного файла msi, который запрашивал бы подтверждение на запуск.

скорее всего, ты что-то в настройках венды накрутил. по умолчанию подтверждение запрашивается.

waker ★★★★★ ()

Во, я вспомнил чего не хватает. Кнопки «Сделать нормальную громкость голоса в фильмах с 5.1 дорожками на стерео колонках». Я черт знает что нужно настроить в системе, что бы все звуковые эффекты фильма прекратили бить по ушам, а персонажей стало слышно.

PtiCa ★★★★★ ()
Последнее исправление: PtiCa (всего исправлений: 1)
Ответ на: комментарий от Pro100User

Да, я помню, и звука-то особо не было. Одна музыкальная моно-дорожка, и надписи на экране вместо голосов. «Полет на луну» был бестселлером, красотища! Можно было смотреть даже на ИМ-02, никаких проблем.

PtiCa ★★★★★ ()
Ответ на: комментарий от umren

Такой, похожий на Natron. Я пользовался, нифига не понял - интерфейс не интуитивный и видеоуроков мало. И по сравнению с After Effects, кажется, что нет фич.

Skullnet ()
Последнее исправление: Skullnet (всего исправлений: 1)

Не хватает GUI для bluetooth не прибитого к питону, гному, kde и т.п. Для использования в простых дистрибутивах.

Запилил на гитхабе репозитарий, думаю сделать вариант на основе скриптов из Puppy

irton ★★★★ ()
Ответ на: комментарий от Skullnet

ты шутник что ли? nuke имеет в сто раз больше фич, афтер эффектс это маргинальная программа в индустрии композинга которой пользуются школьники клипмейкеры по сравнению с nuke ;)

umren ★★★★★ ()
Ответ на: комментарий от MimisGotAPlan

Линус что-то там говорил про обратную совместимость. Не помнишь? Вот пока эта позиция не изменится не будет под линь ни дров ни софта.

ни софта

А ты знаешь, о чем он говорил?

templarrr ★★★★★ ()
Ответ на: комментарий от templarrr

Да, и софта не будет потому что никому нахрен не нужно писать софт под ОС, на которой нихрена не пашет оборудование.
Вот ты будет писать софт под, скажем, freeDOS? Или Колибри? Или РеактОС? Нет? Ну вот никто и не пишет.

MimisGotAPlan ()
Ответ на: комментарий от templarrr

Почему же нет? Есть. Тщательно подобранное чтобы работало из-под Линукса.
Возьми случайный сканер/принтер/планшет и он не заведётся.
Возьми любой неширпотреб и он не заведётся.
Возьми видеокарту и поймай тонну глюков если заведётся.
Возьми PCI звуковую карту и слушай тишину.
Но у тебя всё работает. Хорошо быть тобой.

MimisGotAPlan ()

Мне Far Manager не хватает полноценного. И чтобы когда я жмакаю Shift+Enter запускался ещё один экземпляр консоли и там выполнилась введённая ранее в консоли команда.

nimdamsk ()

Как разработчику АСУ ТП не хватает: 1.САПР. К сожалению QElectroTech не дотягивает до EPLAN. 2.CODESYS 2.3 работает только под Wine. Появится ли нативный аналог? 3. Что с программированием ПЛК Siemens. Есть софт? 4. SCADA - Open Scada выручает во многих проектах, но есть ли достойные аналоги?

FreeFarEast ()