LINUX.ORG.RU

Версии пакетов


0

0

Привет коллеги, при установке некоторого пакета apt-get мне сообщил что при установке будут удалены следующие пакеты .. и перечилил их. среди них есть те, которые мне, вообще говоря, нужны например libc6-dev, initrd-tools, .. Еще он сообщил что будет установлен (upgrade) новый пакет libc6.. Т.е. я так понял, что моя версия libc6 стара для устанавливаемого пакета. Наверное, есть возможность сохранить обе версии? Подскажите пожалуйста где можно почитать об этом или куда смотреть, в общем что угодно. Или единственная возможность - обновить все пакеты до версии той либы (libc6).. Большое спасибо! Т.е. хотелось бы переключать между версиями, когда запускаешь, например, одно - триггер устанаваливается на одну версию libc6, запускаешь другую программу - верси libc6 меняется (подставляется другая). дистрибутив - ubuntu


Re: Версии пакетов

Вероятно ты устанавливаешь софт не из родного репозитария (типа на stable ставишь пакет из testing/unstable).

Если да, то так, как правило, нельзя делать.
Скачивай deb-src (testing/unstable) пакет и собирай его в своей системе

sdio ★★★★★ ()
Ответ на: Re: Версии пакетов от sdio

Re: Версии пакетов

да: именно так и пытался. Действительно - надо было просто брать исходники. Но тогд анужны исходники всех зависимых пакетов.. Спасибо!

diglan ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.