LINUX.ORG.RU

Проблемы с AMDGPU

 , , ,


0

1

Итак, Athlon 5370 со встроеным видеоядром Sea Islands. Драйвер - Amdgpu.

VGA - все работает отлично, хоть на Radeon, хоть на Amdgpu.

Подключаю HDMI и начинаются проблемы. Картинка шикарная (прямо не понимаю как раньше жил без HDMI) звука нет. C параметром amdgpu.dc=1 звук появляется, а вот изображение летит к чертям. Сглаживания - ноль, вместо шрифтов - лесенки, контрастность такая, что не видно разницы между черным и серым цветом. Артефактов нет, все грузится и работает как обычно.

А теперь самая мякотка. Скриншот приложить не могу, потому что скриншот всего этого безобразия выглядит НОРМАЛЬНО! То есть, вообще никакой разницы с amdgpu.dc=0

Radeon по HDMI рисует такой же ужас.

Куда копать? Есть заклинания чтоб включить звук, не включая DC? Настройки моника не помогают вообще никак. Да и не моник это, а телек.

P.S. Gnome, Wayland.

★★★

Ответ на: комментарий от Keltir

Проверил все что только можно. Другой кабель, другой комп, другой комп с другим кабелем :-) Проблема явно в этом железе.

qtm ★★★ ()

Да и не моник это, а телек.

Так подключи монитор - проверь, может дело в устройстве отображения.

iZEN ★★★★★ ()

А теперь самая мякотка. Скриншот приложить не могу, потому что скриншот всего этого безобразия выглядит НОРМАЛЬНО! То есть, вообще никакой разницы с amdgpu.dc=0

сфоткай на телефон, хуль

Настройки моника не помогают вообще никак. Да и не моник это, а телек.

у меня тоже телек, и тоже катастрофа вместо изображения по дефолту, но мне таки помогли настройки (переключение режима)

и таки да, по VGA всё норм сразу

и до этого был китайский телевизор с такой же проблемой

с большой долей вероятности, драйвер тут вообще не при делах.

Ford_Focus ★★★★★ ()
Последнее исправление: Ford_Focus (всего исправлений: 3)
Ответ на: комментарий от iZEN

Да нет у меня монитора и взять не у кого. Но, понятно, что стоит проверить и это.

qtm ★★★ ()
Ответ на: комментарий от Ford_Focus

и до этого был китайский телевизор с такой же проблемой

Тоже китайский. И особых настроек там никаких нет. А те, что есть я уже потыкал.

у меня тоже телек, и тоже катастрофа вместо изображения по дефолту

Дык, по дефолту у меня все норм с изображением. Проблемы появляются если DC врубить. Подсовывал патченный под RGB EDID - ноль реакции. Хотя патчи применяются. В настройках видно.

qtm ★★★ ()

Попробуйте вытащить процессор и выкинуть его. Я уже сделал так и это помогло. Просто на ЛОРе полно оленей, который выступают за опен-сорц. Вот только ломкая трёхнейронная система не даёт понять, что давно пора игнорировать производителей, которые не подвозят дрова в Линукс. Просто сливать их и всё.

anonymous ()

Да и не моник это, а телек.

Копайтесь в настройках телека. Они любят всякие оверсканы и «улучшители» картинки. Возможно на вашем телеке это можно отключить.

erfea ★★★★★ ()
Ответ на: комментарий от qtm

Тоже китайский. И особых настроек там никаких нет.

Дык, по дефолту у меня все норм с изображением. Проблемы появляются если DC врубить.

Поздравляю, очевидно, товарищи китайцы порешили что без звука это источник графики и её ломать ненадо, а со звуком это кино и его, конечно же нужно улучшить. А драйвер по-дефолту включает единственный правильный режим для этого китайского барахла. Ибо обычно он таки звук на монитор отправляет без каких либо параметров ведра.

erfea ★★★★★ ()
Ответ на: комментарий от qtm

Значит dc=1 ещё что-то меняет помимо вывода звука. В любом случае телевизор - плохой монитор, а плохой телевизор догадаетесь сами.

erfea ★★★★★ ()

а в чём смысл гонять звук на телек по HDMI, если там говённая акустика?

подключи нормальную акустику к звуковой плате.

annerleen ★★★★★ ()
Ответ на: комментарий от qtm

Другой кабель, другой комп, другой комп с другим кабелем :-)

другое ядро (старее/новее/из git), другой дистрибутив — пробовал?

annerleen ★★★★★ ()
Ответ на: комментарий от erfea

Вот мне и интересно что. Скриншот-то нормальный получается, а на экране дерьмо собачье.

qtm ★★★ ()
Ответ на: комментарий от annerleen

Шоб було. Так-то я наушниками пользуюсь 95% времени. Но иногда требуется и общий звук прогнать, а городить для этого лапшу из проводов совсем не хочется.

На ЛТС-ядре у меня другие проблемы вылезут, так что не пробовал. А вот на пару версий откатывал и другой дистр тоже. Аналогично.

qtm ★★★ ()

У меня совершенно точно нет звука по HDMI в Linux на телевизор Hisense при его родном EDID.

Случайно починил звук, когда подсовывал ему чужой EDID ради 4К@60.

Давно было. Сейчас вот посмотрел - оригинальный и измененный (спёртый из Samsung) EDID отличаются в блоке CEA Extensions - Audio, кажется, только наличием в последнем декларации DTS и несколько другой декларацией LPCM по частотам и каналам.

Но я не спец - не знаю какое именно место в EDID починило звук случайно.

Toxo2 ★★ ()
Ответ на: комментарий от Toxo2

Попробую и там EDID потыкать. Но из того что я нагуглил - отсутствие звука проблема чисто амдгпушная. Включается и выключается по DС. То есть, не телек звук не играет, а сама система не видит звуковуху.

qtm ★★★ ()
Последнее исправление: qtm (всего исправлений: 1)
Ответ на: комментарий от qtm

отсутствие звука проблема чисто амдгпушная

да, забыл уточнить - у меня это на AMD Radeon RX 550 происходит.

Toxo2 ★★ ()
Ответ на: комментарий от qtm

amdgpu.dc (Display Core) это совершенно другая история и к звуку не имеет отношения.

чини звук без amdgpu.dc=1, если не чинится — пиши багрепорт.

annerleen ★★★★★ ()
Ответ на: комментарий от annerleen

Я кучу ключей перепробовал, но реально звуковуха определяется системой только когда DC=1. Поэтому и спрашиваю, есть ли возможность врубить звук, оставив DC=0.

qtm ★★★ ()
Ответ на: комментарий от qtm

Честно говоря я сто лет это не проверял - сейчас загрузился в ArchLinux свежий и железный посмотреть из любопытства.

Всё ровно так же, как и было:

Если с drm.edid_firmware=HDMI-A-1:edid/hecmod.bin загружать - всё прекрасно звучит в телевизоре (это модифицированный EDID из Samsung).

Если убрать этот параметр из cmdline, то звука просто нет. Судя по всему - Linux уверен, что всё хорошо и он честно играет. И карту так же Baffin HDMI/DP Audio определяет, и Audocious моргает палочками анализатора спектра - всё выглядит так, словно всё хорошо. Но Звука Просто Нет. Тишина. )

Toxo2 ★★ ()
Последнее исправление: Toxo2 (всего исправлений: 1)
Ответ на: комментарий от Toxo2

Ну вот. А у меня не определяет и не моргает. Нет устройств вывода. Ноль. Пусто. Нечем играть. Врубишь dc - сразу появляется звуковуха, ставится по дефолту, играет и моргает.

qtm ★★★ ()

Если это всратый телек, посмотри на телеке как он подключён hdcp 2.0 или 1 или авто. В этом говне скрыта туча проблем. С 2.0 у меня даже уефи не видать, если по горячему подключить то работает кое как

anonymous ()

Проблема в линуксе

Советую сменить дистрибутив

anonymous ()
Ответ на: комментарий от anonymous

ВРЁТИ! АМД САМАЯ ОПЕНСОРСНАЯ КАМПАНИЯ

anonymous ()
Ответ на: комментарий от qtm

без костылей с hdmi и телеками толком нигде не обходятся. ну вот консоли только норм работают и некоторые медиаплееры. а в пека через шдми тока мониторы без проблем цепляются.

Thero ★★★★★ ()
Ответ на: комментарий от Thero

очень сильно сомневаюсь, иначе об этом написали бы на арчевики.

бтв, на той же арчевики из звукопроблем только это:

Double-speed or «chipmunk» audio, or no audio when a 4K@60Hz device is connected

This is sometimes caused by a communication issue between an AMDGPU device and a 4K display connected over HDMI. A possible workaround is to enable HDR or «Ultra HD Deep Color» via the display's built-in settings. On many Android based TVs, this means setting this to «Standard» instead of «Optimal».

ТС, у тебя случайно не 4K@60Hz?

annerleen ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей