LINUX.ORG.RU

Проблема со звуком

 , , ,


0

1

Добрый день, возникла проблема. После установки Blink SIP (устанавливал через flathub) начались проблемы со звуком. В чем прикол: при подключении наушников к заднему разъему ПК звук норм, но если делать звонки через SIP то начинается шипение и тд, при этом если выводить звук на колонки монитора то телефония работает хорошо и звук норм. Затем и на колонках может начаться шипение, решается проблема перезапуском пульсаудио. Уже и не знаю куда глядеть, пересел на Ubuntu недавно. Ubuntu 20.04 версия ядра 5.4.0-52. Еще заметил особенность, когда использую blink, в настройках звука, появляется для микрофона и колонок модуль ALSA python2.7 У меня питон 3.8, более старого не установлено ¯_(ツ)_/¯


Еще заметил особенность, когда использую blink, в настройках звука, появляется для микрофона и колонок модуль ALSA python2.7 У меня питон 3.8, более старого не установлено ¯_(ツ)_/¯

Можно скрин этих устройств? Из описания не понял о чем речь.

В чем прикол: при подключении наушников к заднему разъему ПК звук норм, но если делать звонки через SIP то начинается шипение и тд, при этом если выводить звук на колонки монитора то телефония работает хорошо и звук норм.

Используешь наушники и Blink выводишь на них, звук шипит. Затем переключаешь блинк на колонки, или все звуки на колонки?

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от altwazar

Используешь наушники и Blink выводишь на них, звук шипит.

Да, именно так

Затем переключаешь блинк на колонки, или все звуки на колонки?

Вывожу весь звук и там уже по разному. Могу вывести и звук на колонки и он нормальный, а может продолжать шипеть. Такое наблюдается когда начинаю пользоваться Blink.

Можно скрин этих устройств? Из описания не понял о чем речь.

https://imgur.com/a/vlYHyUW

ystoq ()
Ответ на: комментарий от ystoq

https://imgur.com/a/vlYHyUW

Ясно. Но ничего не обычного, это просто blink умеет выводить только в алсу и выводит через переходник в pulseaudio.

До 20.04 проблем не было? Можно попробовать в /etc/pulse/default.pa заменить:

load-module module-udev-detect

на

load-module module-udev-detect tsched=0

Не факт что поможет, но при странном шипении пульсы стоит попробовать (надо перезагрузить пульсу/пк).

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от altwazar

До 20.04 проблем не было?

Не могу сказать, т.к. я изначально ставил 20.04 версию

Можно попробовать в /etc/pulse/default.pa заменить

Изменил, перезапустил пульсу, результат такой же(

ystoq ()
Ответ на: комментарий от ystoq

Даже хуже стало, через колонки теперь начал звук шипеть, при использовании Blink

Тогда надо убрать, явно не оно.

Звук напоминаешь шипение, потрескивание или потрескивание с посторонними призвуками (будто бы металическая труба пердит)?

Возможен еще один баг, но на встройках мне не встречался. Суть в том, что приложение с выводом в алсу стучиться на карточку и у неё переключается частота дискретизации вывода. Пульса же о переключении не в курсе.

Проверить можно так: в /etc/pulse/daemon.conf заменить строки:

; default-sample-rate = 44100

; alternate-sample-rate = 48000

на (раскомментировать и заменить 44100 на 48000):

default-sample-rate = 48000

alternate-sample-rate = 48000

Это сломает переключалку в пульсе и она всегда будет выводить в 48000. Тоже не факт что поможет, редкий баг.

У тебя весь звук шипит после проявления бага (музыка и т.п.), или только звук в блинке?

altwazar ★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от ystoq

Может имеет смысл отключить пульс и попробовать через чистую алсу?

Можно, но это тянет за собой другие проблемы. Это вполне может быть багом самой пульсы.

altwazar ★★ ()
Ответ на: комментарий от altwazar

У тебя весь звук шипит после проявления бага (музыка и т.п.), или только звук в блинке?

Только в блинке. Сейчас попробую отредачить daemon.conf

Звук напоминаешь шипение, потрескивание или потрескивание с посторонними призвуками (будто бы металическая труба пердит)?

Потрескивание

ystoq ()
Ответ на: комментарий от altwazar

Это сломает переключалку в пульсе и она всегда будет выводить в 48000. Тоже не факт что поможет, редкий баг.

Попробовал отредактировать daemon.conf, результат не изменился - закоментировал обратно.

Это вполне может быть багом самой пульсы.

Может, но есть одно но. Наушники я подключаю порту на компе, к матернике проще говоря. Колонки у меня в мониторе, монитор подключен по HDMI, т.е. звук идет по HDMI, при переключении на колонки. В мониторе есть разъем под наушники, когда подключаю туда, то звук идеальный и чистый.

ystoq ()
Ответ на: комментарий от ystoq

Может, но есть одно но.

Как я понял, то у тебя и на колонках бывает шипение (HDMI). Значит настройку звуковушки можно опустить. Тут либо баг в пульсаудио (но странно, что проблема только с одним приложением), либо в блинке.

Можно в качестве эксперимента попробовать какой-нибудь зойпер.

altwazar ★★ ()
Ответ на: комментарий от altwazar

Можно в качестве эксперимента попробовать какой-нибудь зойпер.

Поставил зойпер и чудо, все работает отлично. Видимо, что проблема в самом Blink. Буду пользоваться зойпером. Спасибо за помощь :)

ystoq ()