LINUX.ORG.RU

Ответ на: комментарий от targitaj

Не удовлетворяются. Надо с sid репозитория или с убунты пересобирать, но так ломается система, системные бибилиотеки нельзя туда совать, потому что стабильность системы нарушается.

serhey ()
Последнее исправление: serhey (всего исправлений: 2)
Ответ на: комментарий от serhey

Насколько я вижу, там вот такие зависимости указаны:

libpulse0 libasound2 libnss3 libssl1.0.0 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-libav
И если посмотреть, как их можно удовлетворить, то получается нечто такое:
apt list libpulse0 libasound2 libnss3 libssl1.0.0 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-libav 2>/dev/null |grep amd64
gstreamer1.0-libav/stable,unstable,now 1.15.0.1+git20180723+db823502-2 amd64 [installed]
gstreamer1.0-plugins-base/stable,unstable,now 1.14.4-2 amd64 [installed]
gstreamer1.0-plugins-good/stable,unstable,now 1.14.4-1 amd64 [installed]
gstreamer1.0-plugins-ugly/stable,unstable,now 1.14.4-1 amd64 [installed]
gstreamer1.0-pulseaudio/stable,unstable,now 1.14.4-1 amd64 [installed]
libasound2/stable,unstable,now 1.1.8-1 amd64 [installed,automatic]
libgstreamer-plugins-base1.0-0/stable,unstable,now 1.14.4-2 amd64 [installed]
libgstreamer1.0-0/stable,unstable,now 1.14.4-1 amd64 [installed]
libnss3/stable,now 2:3.42.1-1 amd64 [installed]
libpulse0/stable,unstable,now 12.2-4 amd64 [installed,automatic]
libssl1.0.0/oldoldstable,now 1.0.1t-1+deb8u8 amd64 [installed]
Как видим, все пакеты, кроме libssl1.0.0, есть в текущем стабильном, то есть в buster (он же Debian 10).

Так что возьми libssl1.0.0 из jessie (она же oldoldstable, она же Debian 8), установи, и будет тебе счастье.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u11_amd64.deb Selecting previously unselected package libssl1.0.0:amd64. dpkg: regarding libssl1.0.0_1.0.1t-1+deb8u11_amd64.deb containing libssl1.0.0:amd64, pre-dependency problem: libssl1.0.0 pre-depends on multiarch-support multiarch-support is not installed.

dpkg: error processing archive libssl1.0.0_1.0.1t-1+deb8u11_amd64.deb (--install): pre-dependency problem - not installing libssl1.0.0:amd64 Errors were encountered while processing: libssl1.0.0_1.0.1t-1+deb8u11_amd64.deb

serhey ()
Ответ на: комментарий от anonymous

Под арчем этот вибер запускается и пересобирать под него ничего не нужно, ничего не ломается.

А пофигу. У меня под Арчем тоже ничего не ломается(потому что Арча у меня нет), но я не лезу со своим Арчем во всякую не относящуюся к нему тему.

Partisan ★★ ()
Ответ на: комментарий от serhey

(На всякий случай) На мой взгляд, хороший совет: добавь в /etc/apt/sources.list строки для stretch и jessie и устанавливай старые пакеты обычным apt, если понядобятся. У меня они такие:

deb http://ftp.se.debian.org/debian/ jessie main contrib non-free
deb http://ftp.se.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free

Вреда от этого почти нет (места для /var/lib/apt требуется больше разве что). Но чуть больше аккуратности при установке пакетов потребуется (иногда старый пакет требует старую версию другого пакета, а уже установлен новый, тогда ой).

TeopeTuK ★★★ ()
Ответ на: комментарий от Partisan

но я не лезу со своим Арчем во всякую не относящуюся к нему тему.

Ты не лезешь, а я буду лезть. Арч решает проблему? Решает. Какие ещё вопросы?

anonymous ()
Ответ на: комментарий от meliafaro

Распаковать deb, закинуть либу, но не в системный каталог, а в каталог к проприетарному зонду, перед запуском зонда прописать путь к либе в переменную LD_LIBRARY_PATH.

chuzhoi ()
Ответ на: комментарий от anonymous

У каждого дистрибутива есть своё применение. Мне нравиться Ubuntu на рабочем столе и Debian на сервере. Может Арч решает проблему, но взамен предоставляет ещё десять новых. Горе таким «Советчикам».

anonymous ()