LINUX.ORG.RU

Артефакты при воспроизведении видео в Chromium с аппаратным ускорением.

 , , , ,


0

2

Система — Debian 10. Поставил Chromium 75 из Sid, видео начало воспроизводиться с жуткими артефактами.

Вроде бы такое было и на Chromium 73, но там я отключал аппаратное ускорение через flags, а сейчас там этой опции нет. Но точно не помню.

Видео воспроизводится (или декодируется) через MojoVideoDecoder. Видеокарта — старая Radeon HD 5400. Как можно пофиксить? Чур сменить AMD на видеокарту не предлагать.

chrome://gpu/

Canvas: Hardware accelerated
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Disabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Out-of-process Rasterization: Hardware accelerated
Hardware Protected Video Decode: Hardware accelerated
Rasterization: Hardware accelerated
Skia Renderer: Disabled
Surface Control: Disabled
Surface Synchronization: Enabled
Video Decode: Hardware accelerated
Viz Service Display Compositor: Enabled
Viz Hit-test Surface Layer: Disabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated

Ответ на: комментарий от AbbaT

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=926032

Now that I know, there are some bugs in that version which makes hardware acceleration ON always, and the option to revert to software rendering is gone.

Короче

sudo apt install snapd

sudo snap install chromium

Будет браузер без GPU декодирования

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 4)
Ответ на: комментарий от fornlr

Removing the option to enable/disable hardware accel is the right move to get rid of the problem at the moment. However this last patch (Source-Version: 75.0.3770.90-1) does the exact opposite of its intent : the option to enable/disable accel is removed AND hardware accel is now always on instead of being disabled by default.

Приколотили гвоздями.

AbbaT ()