LINUX.ORG.RU
ФорумAdmin

[Apache] local <-> remote charset conversion


0

0

хочу поинтересоваться , есть ли что-то подобное у апаче? Или, не поделитесь, каким-нибудь решением?

А то вот такое положение дел: кодировка в браузере cp1251 выбирается и все, ладно у меня в лисе utf-8 задам, но многим при просмотре и оценки содержимого не до этого

В страницах же (x)html присутствуют строчки с

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
но все равно cp1251 получается и в результате в браузере крякозябры

В /etc/httpd/httpd.conf пробовал задавать для виртуального хоста

AddDefaultCharset UTF-8
AddType "text/html; charset=UTF-8" .html .htm .shtml
в браузере по-умолчанию все равно вин, а не юникод

★★★★★

хедеры какие в ответе?

В браузере по-умолчанию стоит «брать кодировку из ответа сервера».

true_admin ★★★★★ ()

AddDefaultCharset utf-8
и все работает.

Скорее всего, проблема в кривом браузере.

nnz ★★★★ ()
Ответ на: комментарий от true_admin

Извиняюсь, не понял, в плане хедеры?

это что ли

  HeaderName HEADER.html
пробовал комментировать и так оставлять, результат такой же

или вот еще в конфиге подключен следующий модуль

LoadModule headers_module lib/httpd/modules/mod_headers.so
NK ★★★★★ ()
Ответ на: комментарий от true_admin

$ wget -S -O /dev/null http://localhost:ПОРТ/dev

--2010-05-10 02:21:31--  http://localhost:ПОРТ/dev
Распознаётся localhost (localhost)... 127.0.0.1
Устанавливается соединение с localhost (localhost)|127.0.0.1|:ПОРТ... соединение установлено.
Запрос HTTP послан, ожидается ответ... 
  HTTP/1.1 301 Moved Permanently
  Date: Sun, 09 May 2010 22:21:31 GMT
  Server: Apache
  Location: http://localhost:ПОРТ/dev/
  Content-Length: 295
  Keep-Alive: timeout=5, max=100
  Connection: Keep-Alive
  Content-Type: text/html; charset=iso-8859-1
Адрес: http://localhost:ПОРТ/dev/ [переход]
--2010-05-10 02:21:31--  http://localhost:ПОРТ/dev/
Повторное использование соединения с localhost:ПОРТ.
Запрос HTTP послан, ожидается ответ... 
  HTTP/1.1 200 OK
  Date: Sun, 09 May 2010 22:21:31 GMT
  Server: Apache
  Last-Modified: Mon, 03 May 2010 20:33:23 GMT
  ETag: "37082-11af-485b68114aac0"
  Accept-Ranges: bytes
  Content-Length: 4527
  Keep-Alive: timeout=5, max=99
  Connection: Keep-Alive
  Content-Type: text/html; charset=utf-8
Длина: 4527 (4,4K) [text/html]
Saving to: «/dev/null»
NK ★★★★★ ()
Ответ на: $ wget -S -O /dev/null http://localhost:ПОРТ/dev от NK

Возможно, проблема в том, что при перенаправлении выдается другая кодировка (может, твой браузер индусы писали). А может, в пробеле после «text/html;».

Но скорее таки в неправильных настройках браузера.
На других браузерах/компах тестировал?

nnz ★★★★ ()
Ответ на: комментарий от nnz

попробуй кодировку указать так

Alias /dev/ «/путь к твоему dev/»

<Directory «/путь к твоему dev»>

Options -Indexes FollowSymLinks MultiViews

Order allow,deny

Allow from all

AddDefaultCharset UTF8

</Directory>

dr0n ()
Ответ на: комментарий от dr0n

Это не мне надо было адресовать. УМВР :)

nnz ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.