LINUX.ORG.RU
ФорумAdmin

Oracle не ставиться


0

0

Oracle 9i. При запуске ./runInstall с диска возникает следующая ошибка: Initializing Java Virtual Machine from /tmp/OraInstall2007-09-29_12-50-22PM/jre/bin/java. Please wait... /tmp/OraInstall2007-09-29_12-50-22PM/jre/bin/i386/native_threads/java: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

Я скачал libstdc++-2.10.0-1nw5.armv4l.rpm и попробовал поставить, но ничего невышло. После rpm -i libstdc++-2.10.0-1nw5.armv4l.rpm выдало следующее: ошибка: Неудовлетворенные зависимости: /sbin/ldconfig нужен для libstdc++-2.10.0-1nw5 ld-linux.so.2 нужен для libstdc++-2.10.0-1nw5 libc.so.6 нужен для libstdc++-2.10.0-1nw5 libm.so.6 нужен для libstdc++-2.10.0-1nw5

Если сталкивались с подобным подскажите. Заранее благодарен.


Ответ на: Re: Oracle не ставиться от ECLIPSE

Re: Oracle не ставиться

вобще на нормальных линуксах такие сообщения бывают если недоустановлены библиотеки из пре-рекварных, в частности когда я ставил оракл 10Г на Центос4, получил аналогичное сообщение, оказалось что нужно ставить две версии одноименной либы compat-libstdc++-296 и compat-libstdc++-33 а я поставил только одну из них. Проблема решилась просто, как и сама команда yum install compat-libstdc++-33

что там надо делать в слаке - патрег ево знает, если вообще можно что либо сделать, поскольку либы эти глубоко системные, и замене не подлежат. Не могу сказать что мне вас жаль коллега, вы сами выбрали свой гимор, но всёже любопытно, поставите или нет...

sa22 ()

Re: Oracle не ставиться

Ясно.. Тяжёлый случай.. Тебе нужно доставить необходимое ПО и, при надобности, слинковать нужное..

http://roqet.org/oracle_on_slackware.html

MiracleMan ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.