LINUX.ORG.RU

Проблема с выводом звука на встроенные динамики Dell 1018

 , , , ,


0

1

Комрады, нужна помощь!
Есть нетбук Dell Inspirion 1018, у которого очень интересный баг: при попытке воспроизвести звук, например плеером, во встроенных динамиках глухо, а вот при подключении наушников в самих наушниках звук есть. При отключении наушников звук появляется в динамиках, но до окончания работы программы. Если плеер закрыть и снова открыть, то звука снова не будет и надо всё повторять сначала.

Дано:
* Ubuntu 14.04.1 x86;
* Realtek ALC272;

Вот похоже этот баг https://bugs.launchpad.net/ubuntu/ source/alsa-driver/ bug/1320020

Существует ли какое-то решение?

★★★★★
Ответ на: комментарий от Nuzhen_tolko_lin

Не, так не прокатит - давайте менее радикально.

vilisvir ★★★★★ ()

Стоит понаблюдать за уровнями громкости в alsamixer до подключения наушников, с ними, и после отключения с работающими динамиками.

Так же при подключении наушников pulseaudio может переключить порт. Тоже можно посмотреть и самому попробовать переключать его в pavucontrol.

Еще стоит посмотреть две вещи:

в alsamixer «auto mute». По хорошему должен отключать звук на колонках при подключении наушников, но иногда он реагирует на что угодно, и отключает тоже что угодно.

В /etc/pulse/default.pa автоматическое переключение порта:

load-module module-switch-on-port-available

Так же можно задокументировать эту строчку и посмотреть, какая реакция будет на подключение/отключение наушников. Ситуация схожа с «auto mute».

altwazar ()
Ответ на: комментарий от altwazar

Спасибо за развёрнутый ответ!

Стоит понаблюдать за уровнями громкости в alsamixer до подключения наушников, с ними, и после отключения с работающими динамиками.

Просто исчезает и появляется уровень динамиков. Как при первом так и при последующих подключениях.

в alsamixer «auto mute». По хорошему должен отключать звук на колонках при подключении наушников, но иногда он реагирует на что угодно, и отключает тоже что угодно.

Игрался - не помогает.

в alsamixer «auto mute». По хорошему должен отключать звук на колонках при подключении наушников, но иногда он реагирует на что угодно, и отключает тоже что угодно.

В /etc/pulse/default.pa автоматическое переключение порта:

load-module module-switch-on-port-available

Так же можно задокументировать эту строчку и посмотреть, какая реакция будет на подключение/отключение наушников. Ситуация схожа с «auto mute».

Документирование повлияло на то, что звук появляется только в наушниках.

====================================

Придумал костыль: если на панельке возле часов на значке звука сначала выключить звук, а потом включить, то до окончания сессии звук выводится на динамики.

vilisvir ★★★★★ ()
Ответ на: комментарий от vilisvir

Придумал костыль: если на панельке возле часов на значке звука сначала выключить звук, а потом включить, то до окончания сессии звук выводится на динамики.

Забавно. Похоже порт переключается правильно, но изначально или он выбран не верный, или громкость замьючена или убрана в ноль изначально.

altwazar ()
Ответ на: комментарий от Nuzhen_tolko_lin

пульса не может работать без альсы

snaf ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.