LINUX.ORG.RU

сборка qt проекта младшей версией g++

 , , , ,


0

3

Использую arch linux, есть необходимость собирать qt5.5.1-проект, используя g++-4.8. Оный я установил, mkspec настроил, но при линковке лезут ошибки cxx, ссылаясь на одну из библиотек qt(вроде core, не помню точно, как и саму ошибку, сейчас нет возможности уточнить). Сборка на актуальном g++ проходит успешно. Правильно я понимаю, что с репозиторной сборкой qt у меня ничего не получится и придется пересобирать его более низкой версией компилятора, или все-таки есть более консервативный способ? Или может можно как-то указать компилятору, чтобы на целевой машине не требовалось выше GLIBCXX_3.4.18, CXXABI_1.3.7?

UPD:

deleted. С этим разобрался. Вопрос не снят.